Permissions to get shadow folders working

If you are having a problem using Vault, post a message here.

Moderator: SourceGear


Posts: 51
Joined: Wed Mar 30, 2011 4:15 pm
PostPosted: Tue Jan 30, 2018 5:26 pm
Beth: We talked on the phone... still trying to get shadow folders to work.

Shadow folders are in on the same machine as Vault. They are not getting updated when I check in a file.

Copied working folder associations from old web config. Tried giving several different identities full access to the folders, including VaultShadowFolderAppPoolIdentity (I think that's what it's called), ApplicationPoolIdentity, NETWORK SERVICE, and IIS_IUSRS. None of these made any difference. Many of them can't really even be selected -- it's as if they don't exist. Somehow I was eventually able to get it to accept them even though I couldn't search for them.

I am not restarting IIS, Vault, or anything else after making any of these changes.

If you have suggestions, let me know.

Craig

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Jan 31, 2018 10:25 am
Go to the Vault admin web page, and click on Vault Plugins. Then test the URL for the Vault Shadow Folders. That URL might need to be updated.
Beth Kieler
SourceGear Technical Support

Posts: 51
Joined: Wed Mar 30, 2011 4:15 pm
PostPosted: Wed Jan 31, 2018 11:39 am
The URL was definitely wrong. I modified it to point to the new server instead of the old one. I noticed it did not change in the list of plugins, so I tried to modify it again and got an error. I thought maybe the page needed to be refreshed so I hit the link to the plugins again and go this error:

Invalid postback or callback argument. Event validation is enabled using <pages enableEventValidation="true"/> in configuration or <%@ Page EnableEventValidation="true" %> in a page. For security purposes, this feature verifies that arguments to postback or callback events originate from the server control that originally rendered them. If the data is valid and expected, use the ClientScriptManager.RegisterForEventValidation method in order to register the postback or callback data for validation.

EDIT: After I went back and tried viewing the list again I was able to see it with my modification. So I changed all the entries that had old URLS, ignoring the fact that I didn't see them updated in the list as I did it. After, when I tried to refresh the list, I got this same error. I logged out and back in and saw that my changes were there.

Shadow folders still don't work,, but I don't think I was ever able to find the right identity to use to give shadow folders the permission it wants. I will call later unless you have a specific suggestion now.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Jan 31, 2018 1:57 pm
We discussed this offline, cleaned up a few URLs in the Vault Plugins, checked the URLs in the web.config files, and added the IIS_IUSRs account to the folder to which it shadows.
Beth Kieler
SourceGear Technical Support

Posts: 51
Joined: Wed Mar 30, 2011 4:15 pm
PostPosted: Wed Jan 31, 2018 9:12 pm
While trying to solve another problem with permissions I was told that IIS_IUSRS is the identity that the general public has while browsing at my website. So giving that user full access to my shadow folders (which in this case is my website) isn't the best idea.

The solution was to enter "IIS AppPool\VaultShadowFolderAppPool" as the user even though it doesn't show up in any list of available users or groups. This sounds vaguely familiar now that I hear it, so I suspect I had to do this last time and just forgot about it.

So.... still works but perhaps a little more correctly. :-) Thanks for your help, Beth.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Thu Feb 01, 2018 8:58 am
Thank you for the update.
Beth Kieler
SourceGear Technical Support

Return to Support (Vault)

Who is online

Users browsing this forum: Google [Bot] and 3 guests