VS 2019 Pending Changes Window Hangs, Indefinitely

If you are having a problem using Vault, post a message here.

Moderator: SourceGear


Posts: 3
Joined: Tue Aug 13, 2019 7:54 am
PostPosted: Tue Aug 13, 2019 9:34 am
VS 2019 Pending Changes Window Hangs, Indefinitely ... So that's basically it in a nut shell. Everything was working fine on Friday, then Monday morning comes around, and I can no longer look at my pending change set via Visual Studio 2019. I still can check out, undo checkout on files; I can still work since I can check out files as well as check them in via the Vault stand alone client but the arrangement is far from perfect as I am completely unable to use the pending checkout window on my Visual Studio. Things I have tried to correct the issue.
-Remove/refresh source bindings.
-Uninstall/Reinstall VS Source Gear extensions.
-Clear local cache.
-Remove link to local source control.
-Restart the visual studio many times.
-Restart my local box

There were several other steps I've taken, but currently I'm at my whits end.

Posts: 481
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear
PostPosted: Tue Aug 13, 2019 10:21 am
Hello,

Sorry to hear that you're experiencing an issue with Visual Studio 2019 and Vault.

Can you please provide us the version of Vault extensions you have installed? Along with your operating system?

You can see your pending changeset dialog but it's frozen? Or does it not appear at all? Can you possibly send over some screenshots?

Can you also check for a VaultVsipClient-VS-16.0.txt file in your %TEMP% directory?

If one is there, can you please compress / attach and email it to support@sourcegear.com (with a reference to this forum thread)? Maybe there's something in the log file that may provide some additional data. Please send the screen shots as well.

Thanks,

Tonya

Posts: 3
Joined: Tue Aug 13, 2019 7:54 am
PostPosted: Tue Aug 13, 2019 10:49 am
Hey,

So yes, it's frozen, I should say partially frozen. So I can tab to the window if it's already open, and close it. but as for the contents, it just shows a frozen image of whatever was behind the window when it opened, for maybe 5-10 mins, and then it goes black.
I'm using SourceGear Vault Standard Extension ver 10.0.3.967
And I'm runing on Windows 10 Pro Ver 1903.

I started logging on my Vault Client as soon as the problem started so that file is indeed being generated. Does it contain any compromising data? If not I'll gladly send it off to support.

Posts: 481
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear
PostPosted: Tue Aug 13, 2019 11:08 am
Hello again,

We have had other reports of a similar problem which was resolved by disabling "Optimize Rendering for screens with different pixel densities" and restarting.

Please let me know if this doesn't help.

Thanks,

Tonya

Posts: 3
Joined: Tue Aug 13, 2019 7:54 am
PostPosted: Tue Aug 13, 2019 4:25 pm
THAT WORKED!!!

Thank you so much.

Posts: 481
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear
PostPosted: Wed Aug 14, 2019 7:37 am
Thank you for the update.

Tonya

Return to Support (Vault)

Who is online

Users browsing this forum: Bing [Bot] and 10 guests