CLI vault.exe Turn Off Proxy

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
ejhansen71
Posts: 60
Joined: Thu Nov 13, 2014 10:12 am
Location: Lake in the Hills, IL

CLI vault.exe Turn Off Proxy

Post by ejhansen71 » Wed Sep 30, 2020 10:50 am

Hi - I am getting a proxy error on Vault standard vault.exe command. In the GUI I have the proxy turned off. How do I get that same setting in the CLI? The Error and System information is below. Thanks!
PS C:\workspaces\vault2git-master> vault.exe VERSIONHISTORY -ssl -host azprd1vault1.healthds.com -username admin -password password -repository Arrow -rowlimit 0 $/arrow
<vault>
<error>
<exception>System.Exception: Proxy Authentication failed. ---&gt; System.Exception: 1022: Proxy Authentication Failed. Please verify your network settings using the Options dialog under the Tools menu in the Vault GUI Client. ---&gt; System.Net.WebException: The remote server returned an error: (407) Proxy Authentication Required.
at System.Net.HttpWebRequest.GetRequestStream(TransportContext&amp; context)
at System.Net.HttpWebRequest.GetRequestStream()
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at VaultClientNetLib.ClientService.VaultService.ValidateServiceVersions(Int32[] clientSupportedVersions)
at VaultClientNetLib.VaultConnection.Login(String strURLBase, String strUserLogin, String strPassword)
--- End of inner exception stack trace ---
at VaultClientNetLib.VaultConnection.Login(String strURLBase, String strUserLogin, String strPassword)
at VaultClientOperationsLib.ClientInstance.Login(String urlbase, String username, String password)
at VaultClientIntegrationLib.ServerOperations.Login(AccessLevelType altCommand, Boolean bAllowAuto, Boolean bSaveSession)
--- End of inner exception stack trace ---
at VaultClientIntegrationLib.ServerOperations.Login(AccessLevelType altCommand, Boolean bAllowAuto, Boolean bSaveSession)
at VaultCmdLineClient.VaultCmdLineClient.ProcessCommand(Args curArg)
at VaultCmdLineClient.VaultCmdLineClient.Main(String[] args)</exception>
</error>
<result>
<success>False</success>
</result>
</vault>

Client Information
Vault Standard Client Version: 10.0.2.936
.NET Framework Version: 2.0.50727.9044
Operating System: Microsoft Windows 10 Enterprise
Service Pack: 0.0
OS Version: 10.0.17763
Total Physical Memory: 10 GB
Time Zone: (UTC-06:00) Central Time (US & Canada)

Server Information
Server Version: 10.0.0.736
.NET Framework Version: 4.0.30319.36627
Operating System: Microsoft Windows Server 2012 R2 Standard
Service Pack: 0.0
OS Version: 6.3.9600
Timezone: (UTC-05:00) Eastern Time (US & Canada)
SQL Version: Microsoft SQL Server 2014 (SP3-GDR) (KB4532095) - 12.0.6118.4 (X64)
Thanks!

Eric

Tonya
Posts: 653
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: CLI vault.exe Turn Off Proxy

Post by Tonya » Wed Sep 30, 2020 2:25 pm

Hi Eric,

Can you please provide us with the exact setting under the GUI Client's options -> Network Settings, proxy section?

Thanks,

Tonya

ejhansen71
Posts: 60
Joined: Thu Nov 13, 2014 10:12 am
Location: Lake in the Hills, IL

Re: CLI vault.exe Turn Off Proxy

Post by ejhansen71 » Thu Oct 01, 2020 10:22 am

Vault Standard Options --> Network Settings --> Proxy --> Do not use a proxy See attached screen shot
Attachments
sg_2.png
sg_2.png (99.94 KiB) Viewed 524 times
Thanks!

Eric

Tonya
Posts: 653
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: CLI vault.exe Turn Off Proxy

Post by Tonya » Thu Oct 01, 2020 3:55 pm

Hi Eric,

Thank you for following up with the requested information.

After some investigating, we realized that the CLC doesn't use the GUI Settings and there is currently not an argument available to turn it off. The default is for the CLC to use whatever is defined for the system. We have logged a bug for this to be resolved in Vault 11, in the meantime you'll have to turn off your proxy system settings in order for the CLC to connect.

Sorry for the inconvenience.

Tonya

Post Reply