Find In Files Not Finding Existing Text

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
teschste
Posts: 6
Joined: Thu Aug 29, 2013 7:34 am

Find In Files Not Finding Existing Text

Post by teschste » Thu Jun 17, 2021 12:44 pm

We randomly have problems with the Find In Files feature not finding things but today I cam across one that I was able to get specific for.

We have a number of .Net projects in Vault, 48 of them in the repository I am currently using. After successfully rebuilding the index to ensure there were no issues there, I ran Find In Files with the following criteria:
  • Searching for: TSS.PostgreSQL
  • Looking in: $
  • Recursive: Checked
  • File Type: *.vbproj (these are plain text files)
  • Exclude Files: Unchecked
  • Search Options: All Unchecked
I know that 24 of the 48 .vbproj files have the content I was looking for (because I ultimately had to go through them manually) but Find In Files did not find any of them.

I have attached one of the .vbproj files for reference (I had to change the extension to .txt because the attach file feature will not accept .vbproj).

Any help in resolving this issue would be appreciated!
Attachments
File Monitor Config.txt
Original Extension was .vbproj
(17.45 KiB) Downloaded 76 times

Tonya
Posts: 709
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Find In Files Not Finding Existing Text

Post by Tonya » Thu Jun 17, 2021 1:32 pm

Hello,

Thank you for the details you provided us with. I have a couple of suggestions/questions.

Can you run Find in Files on a different machine to see if the outcome is the same?

Are any of your folders cloaked?

What version of Vault are you running?

Thanks,

Tonya

Post Reply