Lots of intermittent server errors after upgrading to 5.0.3

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
joshyeager
Posts: 60
Joined: Wed Aug 18, 2004 11:15 am

Lots of intermittent server errors after upgrading to 5.0.3

Post by joshyeager » Fri Apr 23, 2010 11:28 am

Our Vault server used to run version 3.1.9. Last week, we upgraded to 5.0.3 and moved it to a faster server. Since then, we've been getting a lot of exceptions from the server. I haven't been able to figure out why these are happening, so hopefully you can help us. Here are some of the errors we've gotten recently:

----------From the Vault GUI Client, on login----------
Unable to cast object of type 'System.DateTime' to type 'System.String'.

----------From the Vault GUI Client, when trying to Diff a file in the History window, random----------
Exception of type "VaultClientOperationsLib.GetLatestVersionFailedException" was thrown.

----------From our CC.NET server (14382 was the checkin that triggered this build)----------
System.Exception: There is no version 14382 of $/JobTraQ/JobTraQ in SwiftProjects.
at ThoughtWorks.CruiseControl.Core.Sourcecontrol.FortressClient.GetVersion(String repositoryFolderPath, String workingDir, Int64 folderVersion, Boolean useWorkingDir, Boolean deleteItemsThatAreNotInTheRepository)
at ThoughtWorks.CruiseControl.Core.Sourcecontrol.FortressVaultSourceControl.GetSource(IIntegrationResult result)
at ThoughtWorks.CruiseControl.Core.IntegrationRunner.Build(IIntegrationResult result)
at ThoughtWorks.CruiseControl.Core.IntegrationRunner.Integrate(IntegrationRequest request)

----------From the Vault NAnt Task, intermittent----------
System.OverflowException: Arithmetic operation resulted in an overflow.
at VaultClientIntegrationLib.GetOperations.ProcessCommandGetToLocationOutsideWorkingFolder(String[] objectPaths, GetOptions getOptions, String destPath)
at NAnt.Contrib.Tasks.SourceGearVault.vaultgettolocationoutsideworkingfolder.ExecuteTask()
at NAnt.Core.Task.Execute()
at NAnt.Core.Target.Execute()
at NAnt.Core.Project.Execute(String targetName, Boolean forceDependencies)
at NAnt.Core.Tasks.CallTask.ExecuteTask()
at NAnt.Core.Task.Execute()
at NAnt.Core.Target.Execute()
at NAnt.Core.Project.Execute(String targetName, Boolean forceDependencies)
at NAnt.Core.Project.Execute()
at NAnt.Core.Project.Run()

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Re: Lots of intermittent server errors after upgrading to 5.0.3

Post by lbauer » Fri Apr 23, 2010 1:40 pm

Let's start by taking a look at the Vault server log. It's called sgvault.log and is in %windir%\temp\sgvault on the server machine. Send the log zipped up to support at sourcegear.com, Attn: Linda. Please include a link to this forum post.
Linda Bauer
SourceGear
Technical Support Manager

jclausius
Posts: 3603
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Lots of intermittent server errors after upgrading to 5.0.3

Post by jclausius » Mon Apr 26, 2010 12:37 pm

A quick couple of questions, what was the version of CruiseControl.NET on your OLD machine vs. the version of CruiseControl.NET on the NEW machine? Are you using the SourceGear provided plugin for CruiseControl.NET?

The CruiseControl folks changed the API, and our older plugin will not work with CC.NET 1.5. You can contact SourceGear Tech Support for a new plugin which is in testing.
Jeff Clausius
SourceGear

joshyeager
Posts: 60
Joined: Wed Aug 18, 2004 11:15 am

Re: Lots of intermittent server errors after upgrading to 5.0.3

Post by joshyeager » Mon Apr 26, 2010 1:59 pm

Ok, I got the Cruise Control information from our tester. We're using Cruise Control.NET version 1.4.4.83. This is the same version that we were using before the Vault upgrade. We are using the SourceGear plugin.

jclausius
Posts: 3603
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Lots of intermittent server errors after upgrading to 5.0.3

Post by jclausius » Mon Apr 26, 2010 2:38 pm

Then it is safe to rule that out. You're in capable hands with SourceGear Tech Support. Perhaps the log file will help.
Jeff Clausius
SourceGear

joshyeager
Posts: 60
Joined: Wed Aug 18, 2004 11:15 am

Re: Lots of intermittent server errors after upgrading to 5.0.3

Post by joshyeager » Thu Jun 10, 2010 2:29 pm

Just to follow up, we were unable to determine the cause of these problems, but they stopped happening after a server reboot. It's been running stable for the past two months. Thanks, Linda and Jeff, for your help.

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Re: Lots of intermittent server errors after upgrading to 5.0.3

Post by lbauer » Thu Jun 10, 2010 2:38 pm

Thanks for the update. That's good news. : )
Linda Bauer
SourceGear
Technical Support Manager

Post Reply