Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

avery
Posts: 7
Joined: Thu Aug 16, 2012 9:12 am

Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by avery » Thu Aug 16, 2012 9:15 am

Dear All

We found after upgrade to Vault 6.0 the Visual Studio 2010 is very slow, esp when we save the change of the file

Any idea?

We are using Vault 6.0/ Visual Studio 2010/ Resharper 7 and Windows 7

Thanks

Regards
Avery

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by lbauer » Thu Aug 16, 2012 10:25 am

We need to narrow down the problem first.

What version of Vault were you using before Vault 6?

Did your previous Vault client version work fine with Visual Studio 2010 and Resharper 7?

Is the version of Vault Client the only thing that changed on the client machine?

Are you using Enhanced or Classic Client integration?
Linda Bauer
SourceGear
Technical Support Manager

avery
Posts: 7
Joined: Thu Aug 16, 2012 9:12 am

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by avery » Thu Aug 16, 2012 11:55 am

Hi

We are using Vault Standard (Version 5.1.2) with Visual Studio 2010 and Resharper 7. We are using Enhanced Client integration.

The only change on the client machine is upgrade to Vault 6.0

Any idea?

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by lbauer » Thu Aug 16, 2012 5:06 pm

Are there any slowdowns when using the Vault GUI Client? Is it just in Visual Studio?

What type of project(s) are you experiencing the VS slowdowns in?

To troubleshoot this, we'd like to take a look at the Visual Studio and and Vault Server logs.

First, enable debug server logging in the Vault Admin Web Client under Server Settings->Logging->Log Level. The Vault Server log is called sgvault.log and is in %windir%\temp\sgvault on the server machine.

Then enable logging in Visual Studio. If you're using the Enhanced client, this is set in Visual Studio under Tools->Options->Source Control->Integration options, enable Diagnostic logging. The Visual Studio log is called VaultVsipClient.txt and will be in your user's Temp directory, %temp%.

Reproduce the problem, then send me copies of the logs. Let me know what Vault user was experiencing the slowdown and what time it was so I know where to look for in the logs.

Send the logs zipped up to support at sourcegear.com, Attn: Linda. Please include a link to this forum post.
Linda Bauer
SourceGear
Technical Support Manager

avery
Posts: 7
Joined: Thu Aug 16, 2012 9:12 am

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by avery » Fri Aug 17, 2012 6:39 am

Thanks for the response.

I will check the log for you once my colleague back from holiday (28 August)

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by lbauer » Tue Aug 21, 2012 1:09 pm

OK, we'll wait to hear from you.
Linda Bauer
SourceGear
Technical Support Manager

avery
Posts: 7
Joined: Thu Aug 16, 2012 9:12 am

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by avery » Tue Aug 28, 2012 8:04 am

I took a look at the log and I noticed that Vault.GetSolutionSpecificInternalChangeSet() function always take a long time

28/08/2012 14:50:59 <eventengine>: [<No Name>:1] Event fired: VaultClientOperationsLib.LocalRefreshEvent
28/08/2012 14:50:59 <eventengine>: [<No Name>:1] Event fired: VaultClientOperationsLib.ChangeSetItemsChangedEvent
28/08/2012 14:50:59 <vsip ide>: [<No Name>:1] In Vault.GetSolutionSpecificInternalChangeSet()
28/08/2012 14:51:01 <vsip ide>: [<No Name>:1] Leaving Vault.GetSolutionSpecificInternalChangeSet()
28/08/2012 14:51:01 <vsip ide>: [<No Name>:1] In Vault.GetSolutionSpecificInternalChangeSet()
28/08/2012 14:51:04 <vsip ide>: [<No Name>:1] Leaving Vault.GetSolutionSpecificInternalChangeSet()
28/08/2012 14:51:04 <vsip ide>: [<No Name>:1] Solution is selected: False

avery
Posts: 7
Joined: Thu Aug 16, 2012 9:12 am

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by avery » Tue Aug 28, 2012 9:22 am

Any update?

avery
Posts: 7
Joined: Thu Aug 16, 2012 9:12 am

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by avery » Tue Aug 28, 2012 11:49 am

Here is a new log file as attached, All he did is:
Open VS, Check-out default.aspx, edit, chick in, close VS.
Attachments
VaultVsipClient2010.zip
(103.31 KiB) Downloaded 418 times

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by lbauer » Wed Aug 29, 2012 11:43 am

Thanks. I'll consult with our developers on this.
Linda Bauer
SourceGear
Technical Support Manager

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by lbauer » Wed Aug 29, 2012 5:17 pm

I installed Resharper 7.0 and used it with Vault 6 and VS 2010 on Windows 7.

I noticed a slowdown when opening Visual Studio 2010, but not when editing and checking in a file in a website project.

So I could use more information.

What type of project is this?

How large is the entire solution; how many projects?

Are other users experiencing the same slowdown, or is it only this user on this particular machine?
Linda Bauer
SourceGear
Technical Support Manager

brettmas
Posts: 2
Joined: Wed Aug 29, 2012 11:22 pm

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by brettmas » Wed Aug 29, 2012 11:25 pm

I had the same issue with VS2012 Vault 6 and ReSharper 7, I installed the latest version of ReSharper today (v7.0.1098.2760) and the problem seems to have been resolved.
I can't tell if it's the latest version of ReSharper that fixed the issue, or simply reinstalling ReSharper

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by lbauer » Thu Aug 30, 2012 8:13 am

Thanks for the info. I saw Resharper 7.0.1 is available, but I did my testing with Resharper 7.0 and didn't see significant slowdowns. But I already had Vault 6 and Visual Studio installed, then installed Resharper.

Avery -- could you try uninstalling and restalling Resharper, or perhaps upgrading to the latest verion to see if that make a difference?
Linda Bauer
SourceGear
Technical Support Manager

brettmas
Posts: 2
Joined: Wed Aug 29, 2012 11:22 pm

Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SLOW

Post by brettmas » Tue Sep 11, 2012 5:43 pm

Unfortunately after installing another extension VS2012 is again running extremely slow, removing the Vault integration was the only way I could get it running smoothly again.

BSayatovic
Posts: 47
Joined: Thu Jun 25, 2009 12:02 pm

Me too! (Re: Vault 6.0/ Visual Studio 2010/ Resharper 7 - SL

Post by BSayatovic » Wed Oct 24, 2012 10:04 am

avery wrote:We found after upgrade to Vault 6.0 the Visual Studio 2010 is very slow, esp when we save the change of the file ... We are using Vault 6.0/ Visual Studio 2010/ Resharper 7 and Windows 7
Wow! I just upgraded to Vault 6.0 (from 5.0) on Monday and my Visual Studio 2010 (on Windows 7, also with ReSharper 7) is terribly slow. Just moving the caret or saving a file takes seconds! A colleague of mind is having the exact same problem.

Following his lead, also echoed in this thread, I told Vault to go off line in Visual Studio (File -> Vault -> Changing Bindings -> Uncheck Online in the bottom of the dialog). Now it is back to its previous fastness (I'm tearing up with bittersweet emotions).

What happened in Vault 6.0's Visual Studio 2010 integration??

Post Reply