Vault 9 Update, Reboot Required

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
Chiramisu
Posts: 38
Joined: Tue Oct 23, 2012 12:13 pm
Location: Oregon

Vault 9 Update, Reboot Required

Post by Chiramisu » Fri Jan 22, 2016 6:51 pm

I am running Vault 8.0.0.192 on a Windows Server 2008 R2 (x64) and wanting to upgrade to Vault 9. I am logged into the web server as the local Administrator account and have given the sysadmin role to the sgvaultuser login on the SQL Server backend (a separate server also running Windows Server 2008 R2).

While trying to run the installer for Vault 8.0.1.299, as the next update, but I'm getting the attached message which I have never seen in previous updates.

I tried skipping this intermediate version and go directly to version 9, but this produces the same result. I have critical websites and services running on this web server and do not wish to restart it.

Thanks,
Matthew
Attachments
Vault9 Update Reboot Required.png
Vault9 Update Reboot Required.png (17.49 KiB) Viewed 6871 times

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Re: Vault 9 Update, Reboot Required

Post by Beth » Mon Jan 25, 2016 9:47 am

Vault doesn't want a reboot usually, but if something has locked one of the files, then Vault can't force the release.

Try performing an iisreset (Start - Run - and type iisreset) to make sure IIS isn't holding onto anything. Also, check your antivirus to make sure it's not actively scanning the files at the same time.
Beth Kieler
SourceGear Technical Support

Chiramisu
Posts: 38
Joined: Tue Oct 23, 2012 12:13 pm
Location: Oregon

Re: Vault 9 Update, Reboot Required

Post by Chiramisu » Mon Jan 25, 2016 12:18 pm

I was aiming for a solution with the least interruption to my Web Server, so I took a slightly different route than you suggested and rather Recycled all the App Pools belonging to Vault, as listed below (in my case):
  • SgDavAppPool
  • Vault
  • VaultAppPool
  • VaultIndexAppPool
  • VaultNotifyAppPool
  • VaultShadowFolderAppPool
This solved my problem and I have now successfully upgraded my server and clients. Thanks. ;)

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Re: Vault 9 Update, Reboot Required

Post by Beth » Mon Jan 25, 2016 1:41 pm

Thanks for the update.
Beth Kieler
SourceGear Technical Support

leo321
Posts: 1
Joined: Mon Jul 02, 2018 11:29 am

Re: Vault 9 Update, Reboot Required

Post by leo321 » Mon Jul 02, 2018 11:42 am

I have installed Vault 9. My K7 Antivirus is giving this 5017 error while the internet is on. Maybe the firewall is blocking certain system files. Disabling the antivirus stops this problem. But is there an alternative solution where while keeping the antivirus enabled?

Tonya
Posts: 636
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Vault 9 Update, Reboot Required

Post by Tonya » Mon Jul 02, 2018 2:49 pm

Was your installation of Vault 9.x successful?

You refer to a 5017 error message while your internet is enabled. Can you please provide us with more details? I believe there may have been a screenshot that didn't get included in your response. You stated that disabling your antivirus software resolves the problem but the problem is a bit unspecific. Any information you can provide would be helpful.

Thanks,

Tonya

Post Reply