Weird Bug

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
Mordachai
Posts: 84
Joined: Sun Feb 24, 2013 11:58 am

Weird Bug

Post by Mordachai » Mon Mar 27, 2017 3:21 pm

I'm getting this sort of thing appearing from time to time - and it makes no sense:

Why would "ControlState.h" appear in the wrong project in the commit list?

It's in the correct one everywhere else...

(Sometimes I get this then when I say "check in" I get back "no items" - even though there clearly are items)
Attachments
Vault Bug.png
Vault Bug.png (27.26 KiB) Viewed 5403 times

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Re: Weird Bug

Post by Beth » Mon Mar 27, 2017 3:46 pm

Is it possibly shared to that project?

If it's not shared and if you have everything checked into Vault, close Vault and then rename CacheMember_ChangeSetItems in your Vault cache. That should remove any things hanging around. Then reopen Vault and let me know if it shows up again.

If it does show up again, then I'll have more questions for you.
Beth Kieler
SourceGear Technical Support

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Re: Weird Bug

Post by Beth » Tue Mar 28, 2017 8:19 am

If you click the farthest right icon that should change the view from Tree View to List View. That might tell us a full path as well.
Beth Kieler
SourceGear Technical Support

Mordachai
Posts: 84
Joined: Sun Feb 24, 2013 11:58 am

Re: Weird Bug

Post by Mordachai » Tue Mar 28, 2017 11:58 am

The path is correct - it is in the correct project folder & project in Vault. I checked both of those things before posting this here.
I''ll try resetting the cache now.

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Re: Weird Bug

Post by Beth » Tue Mar 28, 2017 12:37 pm

You don't need to reset the entire cache. Just the one cachemember.
Beth Kieler
SourceGear Technical Support

Mordachai
Posts: 84
Joined: Sun Feb 24, 2013 11:58 am

Re: Weird Bug

Post by Mordachai » Wed Mar 29, 2017 10:43 am

This didn't stop me from checking in - just to be clear - it's just wrong.

And when I only try to check in the one file that's in the wrong project - I get an error from Vault saying "nothing checked out"

And I get that type of error every once in a while - makes no sense - figured they may all be the same underlying bug - Vault misassociating files and projects for some reason.

I've already reset the cache (but not my settings) - forget which check boxes that was already - and I haven't had this happen again so far - but I haven't edited that exact file either. Who knows - I'll report it if/when it happens again (and I'll know better what to look for if it refuses to check something in for me).

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Re: Weird Bug

Post by Beth » Wed Mar 29, 2017 10:57 am

Ok, that works.

If you're carrying maintenance, we can have an online meeting when it happens as well.
Beth Kieler
SourceGear Technical Support

Post Reply