Cant log into server after database restore

If you are having a problem using Vault, post a message here.

Moderator: SourceGear


Posts: 1
Joined: Tue Oct 31, 2017 11:44 am
PostPosted: Tue Oct 31, 2017 12:39 pm
Our server which housed our vault database died. Luckily we had an sql server backup of it.

I did a fresh 5.1 server install and after that was able to login through the client.

After that I restored the sgmaster and sgvault databases using sql management studio.

When I try to login through the regular client or the web admin client it gives me an error saying I cant login.

Is this possibly because the database backups I have are from 4.1 ?

Is there a way to query the sgmaster database to find out what server of the server is is?

Thanks in advance.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Nov 01, 2017 7:53 am
The issue here is the order in which actions were performed. The database should be restored first, and then install Vault. Vault will recognize that there are databases already and use them.

One other thing to be aware of is that by upgrading you will need to enter in a new license key, unless you already have no license keys entered at all (free single user edition). All users except admin will be locked out until a Vault 5 license key is added. If you need assistance getting license keys, contact our sales department using the contact information posted here: http://www.sourcegear.com/company/.
Beth Kieler
SourceGear Technical Support

Return to Support (Vault)

Who is online

Users browsing this forum: Google [Bot] and 6 guests

cron