BadImageFormatException was unhandled

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
chauiprise
Posts: 6
Joined: Wed Aug 12, 2015 9:42 am

BadImageFormatException was unhandled

Post by chauiprise » Wed Aug 22, 2018 2:55 pm

I just downloaded VaultClient update via:

http://download.sourcegear.com/Vault/10 ... .1.793.zip

After unzipping to the appropriate location, I could get files from Vault using the Vault Client app.

When trying to run a vault command in my build script (which used to work OK) to get files from Vault server, such as:

vault.exe get -host %VaultHost% -ssl -user %VaultUser% -password %VaultPwd% -repository "Wells" -makewritable -nonworkingfolder "%BasePath%\TempBuildFolder\ExternalLibraries" $/ABC/ExternalLibraries/AjaxControlToolkit.dll

I got the error: Could not load file or assembly VaultClientOperationsLib, version=10.0.1.793, Culture=neutral,...This assembly is built by a runtime newer than the current loaded runtime and cannot be loaded.

Could you tell me how to resolve this error?
Thanks!
Attachments
VaultClientOperationsLib_Error.PNG
VaultClientOperationsLib_Error.PNG (99.92 KiB) Viewed 2776 times

Tonya
Posts: 531
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: BadImageFormatException was unhandled

Post by Tonya » Wed Aug 22, 2018 3:52 pm

Hello,

Have you recently upgraded your SSL version to TLS 1.1 or TLS 1.2? If so, there is a special build you will need to download.

Thanks,

Tonya

chauiprise
Posts: 6
Joined: Wed Aug 12, 2015 9:42 am

Re: BadImageFormatException was unhandled

Post by chauiprise » Fri Aug 24, 2018 7:13 am

Hi Tonya,
All I know is our security administrator has disabled SSL 3.0, TLS 1.0 and TLS 1.1 on our Vault server as they are less secure protocols. He advised us to download that VaultStdGUIClient-DotNet452-10.0.1.793.zip and install it to connect securely to our server.
How do I get a new build for the Vault Client cmd line?
Thanks,
Chau

Tonya
Posts: 531
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: BadImageFormatException was unhandled

Post by Tonya » Fri Aug 24, 2018 7:55 am

Hi Chau,

You can download the Vault Standard CLC client that supports TLS 1.2 here:

http://download.sourcegear.com/Vault/10 ... .1.793.zip

Thanks,

Tonya

chauiprise
Posts: 6
Joined: Wed Aug 12, 2015 9:42 am

Re: BadImageFormatException was unhandled

Post by chauiprise » Fri Aug 24, 2018 8:24 pm

Thanks Tonya! Downloading and installing that zip file helped resolve the issue.

Tonya
Posts: 531
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: BadImageFormatException was unhandled

Post by Tonya » Mon Aug 27, 2018 7:32 am

Thank you for the update. Glad to hear the new client helped.

Tonya

Post Reply