Sync must be called on the UI thread.

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
Alex Batura
Posts: 7
Joined: Sun Mar 17, 2019 5:31 pm

Sync must be called on the UI thread.

Post by Alex Batura » Sun Mar 17, 2019 5:52 pm

I am having exactly the same issue like the one below:

viewtopic.php?f=48&t=23171

My Vault version is 10.0.1(793), VS is 2017
Upgrading the latest Vault VS extension (10.0.2.936) did not resolve the issue.

Please help.

Tonya
Posts: 520
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Sync must be called on the UI thread.

Post by Tonya » Mon Mar 18, 2019 8:12 am

Hello,

Can you please try and download the Visual Studio 2017 Extension from our download page again? It looks like you are still running 10.02.936 and the correct version is 10.02.939:

http://sourcegear.com/vault/downloads.html

Thanks,

Tonya

Alex Batura
Posts: 7
Joined: Sun Mar 17, 2019 5:31 pm

Re: Sync must be called on the UI thread.

Post by Alex Batura » Mon Mar 18, 2019 4:49 pm

Hi Tonya,

Upgrading to the latest version, resolved the issue.
Thank you for your help!

jclausius
Posts: 3617
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Sync must be called on the UI thread.

Post by jclausius » Fri Mar 29, 2019 12:57 pm

Glad that latest release solved the problem
Jeff Clausius
SourceGear

Post Reply