IIS version error

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

DougOlson
Posts: 1
Joined: Mon Apr 11, 2005 5:28 pm

IIS version error

Post by DougOlson » Mon Apr 11, 2005 5:33 pm

Hello,

I downloaded the Vault Server 3.0.6 demo and when I run it on my Windows Server 2003 box the install fails with the error "IIS Version 5.00 or greater is required to install the Vault Server. Please ensure it is installed and run this install again". This server is running IIS 6.0.

Suggestions?

Thanks for your help,

-DougO

Bart

same problem

Post by Bart » Tue Apr 12, 2005 5:10 am

Hi, I have the same problem.
I had a old version on my server.
My problems started with very slow startup of my visual studio.
I downloaded the latest version and got that message also.
Uninstalled old version, same problem

please help,

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Tue Apr 12, 2005 8:00 am

Doug -- was Vault previously installed on your machine as well?

Was IIS running when you tried to install?

Were you running the Server installer from the Vault server machine or from a location on your network? If you were running the installer from a place on the network, try running the installer from the same machine you are installing to.

Is there a vault_install.log file in your %temp% directory? If so, email me that file. Send it to linda at sourcegear.com.
Linda Bauer
SourceGear
Technical Support Manager

Bart

logfile

Post by Bart » Tue Apr 12, 2005 8:25 am

Hi,

There is no vault install log file.
I have a msi log file. see attached file.

thanks
Attachments
MSI67f90.zip
(259 Bytes) Downloaded 905 times

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Tue Apr 12, 2005 8:51 am

We've only had a couple of reports of this, and we're not clear on why this happens. Sometimes it occurs when there's a partial installation of Vault already on the machine -- possibly from an uncomplete uninstall, or if a different user installed Vault and you can't see their data.

Check the machine's registry for instances of "Vault" and delete them.

Then try to run the installer again, making sure you're the machine Admin when you do so.
Linda Bauer
SourceGear
Technical Support Manager

Bart

no solution

Post by Bart » Thu Apr 14, 2005 2:20 am

Didn't work out.
Don't you have some check utility to help?

Thanks Bart

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Thu Apr 14, 2005 8:33 am

If you're installing on Win2003 server, review this KB article to make sure IIS and ASPNET are configured correctly for Windows 2003.

http://support.sourcegear.com/viewtopic.php?t=185

If the installation still fails, let us know and we'll contact the company that designed the installer for further help.
Linda Bauer
SourceGear
Technical Support Manager

Bart

not solved

Post by Bart » Thu Apr 14, 2005 10:16 am

Everything is ok as mentioned in your document.
On this webserver (windows server 2003, webedition) there is already a website under asp.net running without problems.
Please can you help further
Thanks
Bart

Guest

Post by Guest » Fri Apr 15, 2005 4:02 am

Still no luck working around the IIS version error. This is the first install of Vault on the server, but just in case, I searched the registry for reference but didn't find any. The MSI is executed from the c:\doug directory. I couldn't find a vault_install.log file, however there was a file named MSI1d0f2.LOG there which contained the following:

"IIS Version 5.00 or greater is required to install the Vault Server. Please ensure it is installed and run this install again."

I check the settings specified in the KB articled above and everything was okay.

Any other ideas or suggestions?

Thanks,

-DougO

mskrobul
Posts: 490
Joined: Wed Jan 14, 2004 10:22 am
Location: SourceGear
Contact:

Post by mskrobul » Fri Apr 15, 2005 9:12 am

I am not sure if this will help in your case or not, but in the past there have weird install issues (not this particular IIS error, but other errors) when the SYSTEM account did not have correct permissions.

Verify that the SYSTEM account has full control permissions for your temp folders (both %windir%\temp and %temp%), the directory that you are installing from (c:\doug), the directory you are installing to, and for the registry.

Also make sure that the user you are logged in as has full control for these areas (you should be logged in as an adminstrator for the machine to install, if you are logged in as an Admin user the permissions *should* be correct).
Mary Jo Skrobul
SourceGear

cesargm
Posts: 1
Joined: Mon Jun 05, 2006 2:25 am
Location: Amsterdam, The Netherlands
Contact:

Solved...

Post by cesargm » Mon Jun 05, 2006 2:31 am

I had exactly the same problem... and it turned out to be that I had Windows 2003 without service packs. After I installed SP1 the problem disappeared.

Cesar

spencen
Posts: 1
Joined: Wed Jun 07, 2006 8:47 pm

Post by spencen » Wed Jun 07, 2006 8:51 pm

I also get the same IIS version error when attempting to install Vault Server on a new Windows Vista Beta 2 (Ultimate) installation. Am running as an Administrator, IIS 7.0 is up and running and SQL Server 2005 is correctly installed and operational.
Has anyone got Vault server to install on Vista Beta 2?

dan
Posts: 2448
Joined: Wed Dec 17, 2003 5:03 pm
Location: SourceGear
Contact:

Post by dan » Thu Jun 08, 2006 8:45 am

Vista isn't supported yet by Vault, and I don't believe anyone here has tried installing it yet.

Maybe someone else out there can chime in?

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Tue May 08, 2007 11:54 pm

I had the same problem.
Server OS = Windows Server 2003 for Small Business Server - SP2.
Vault Server = 3.1.7
Already check http://support.sourcegear.com/viewtopic.php?t=185 & confirm OK except that Active Server Pages is checked apart from World Wide Web Service as shown in www_setup.jpg.
Any help will be much appreciated.
Joel
Micro Modular System
http://www.mmsis.com

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Wed May 09, 2007 2:51 pm

You can also find that information in the IIS Manager. Just go to Web Services Extensions. The version of Vault you have could be using with the 1.1 .NET framework or the 2.0 .NET framework, so try allowing ASP.NET v 1.1 and if that doesn't work try allowing the one for 2.0.

Can you load a client onto the server just for troubleshooting this and use that as your test client?

If allowing both the frameworks in the Web Services Extensions doesn't work, then can you tell me the exact error you are getting or post a screenshot?

Post Reply