IIS version error

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Mon May 21, 2007 2:11 am

Sorry. Caught up with other tasks.
I already have one Vault Server running OK since 2004 - ver 3.1.7 running on .Net Framework 1.1
Right now i am attempting to migrate the Vault to a new server - with better hardware specification & also to allow external access.
I will drop a screenshot once I got my hand in it again.
Anyway, thanks for the respond. It has always been a good experience using Vault. :D
Joel
Micro Modular System
http://www.mmsis.com

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Mon May 21, 2007 2:22 am

Ok - to be a bit more specific, the same problem i refer to is the error message "IIS Version 5.00 or greater is required to install the Vault Server. Please ensure it is installed and run this install again" will appear when i try to install VaultServer.
I will still drop the screen shot.
Joel
Micro Modular System
http://www.mmsis.com

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Mon May 21, 2007 6:11 am

"IIS Version 5.00 or greater is required to install the Vault Server. Please ensure it is installed and run this install again"
This error generally means that the Vault installer cannot gain access to the registry to verify your version of IIS (or make any changes).

Make sure you are logged in to the Vault server machine with full admin privileges. You may also need to change permissions on the registry.
Linda Bauer
SourceGear
Technical Support Manager

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Fri Jun 08, 2007 3:29 am

I have logged in as Administrator & have full access to the system. Please refer to attachment for screen shot of Registry entry for IIS version, IIS Manager setting & error messages. I have even uninstall & re-install IIS component but still the same outcome.
BTW, congratulation to the release of Vault ver 4.0 - i am in the process of convincing my boss to upgrade to this latest version.
Attachments
Vault Server Fail.jpg
Various screenshots of IIS manager & error message
Vault Server Fail.jpg (335.75 KiB) Viewed 6111 times
Joel
Micro Modular System
http://www.mmsis.com

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Sun Jun 10, 2007 4:19 pm

What operating system are you installing Vault on?
Linda Bauer
SourceGear
Technical Support Manager

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Sun Jun 10, 2007 8:43 pm

Windows Small Business Server 2003 R2
Joel
Micro Modular System
http://www.mmsis.com

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Mon Jun 11, 2007 9:59 am

Uninstalling and reinstalling IIS will mean that the same will need to be done with the .NET framework. The .NET framework must be installed after IIS: http://support.sourcegear.com/viewtopic.php?t=22. After you uninstall and reinstall the .NET frameworks, give the install another try to see if the same error occurs.

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Tue Jun 12, 2007 1:44 am

1) Can't uninstall .Net Framework 1.1 - see http://www.dotnet247.com/247reference/m ... 64644.aspx; http://forums.microsoft.com/MSDN/ShowPo ... 5&SiteID=1

2) Just try to reinstall .Net Framework - a meesage appear saying system already contain .Net Framework & installation exit.

3) Run aspnet_regiis -i & try Vault Server installation, the same error message appear. :?
Joel
Micro Modular System
http://www.mmsis.com

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Tue Jun 12, 2007 7:27 am

I've never heard of that. I do it all the time on my test machines. Did you try running aspnet_regiis -u while in the 1.1 .NET directory? (C:\Windows\Microsoft.NET\framework\v1.1.4322).

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Tue Jun 12, 2007 6:08 pm

Yes. In my earlier effort. What OS you run in your Test Machine? Any pointer as to how to uninstall .Net Framework 1.1?
Something in Windows SBS 2003 R2 is preventing the Vault Server installer from identifying IIS 6.0 -
This error generally means that the Vault installer cannot gain access to the registry to verify your version of IIS (or make any changes).
How can i verify that? Which part of the registry entry that Vault Server installer will make the changes?
Joel
Micro Modular System
http://www.mmsis.com

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Wed Jun 13, 2007 6:04 pm

:?
Joel
Micro Modular System
http://www.mmsis.com

gmagana
Posts: 145
Joined: Wed Feb 18, 2004 10:51 am
Location: Santa Ana, CA, USA

Post by gmagana » Thu Jun 14, 2007 12:05 am

On my W2K3 server the IIS version is in

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InetMgr\Parameters

I don't know how/where SourceGear checks for the IIS version, though...
gabriel magana-gonzalez

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Thu Jun 14, 2007 9:37 am

jkp*74:
aspnet_regiis -u is the command for uninstalling IIS. Then one uses the -i switch to install. Try with the -u switch and then with the -i.

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Fri Jun 15, 2007 9:16 am

Hi Beth,

Yes. I have done aspnet_regiis -u & aspnet_regiis -i. Still the same.
After you uninstall and reinstall the .NET frameworks
Can you share some pointer as to how to do that in Windows SBS 2003 R2?
Posted by cesargm I had exactly the same problem... and it turned out to be that I had Windows 2003 without service packs. After I installed SP1 the problem disappeared.
Has anyone installed Vault Server in Windows SBS 2003 R2? Is it the service pack issue?
Joel
Micro Modular System
http://www.mmsis.com

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Fri Jun 15, 2007 1:36 pm

I looked back at your screenshot and noticed that you only have the 1.1 .NET framework allowed in the Web Services extensions. Vault 4.0 REQUIRES the 2.0 .NET framework.

Do you have that framework installed on your machine? If not, you need to download and install the 2.0 .NET framework, then you should probably uninstall (if you got Vault to install) and reinstall Vault.

Post Reply