FYI on 3.1.6

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
Posts: 56
Joined: Mon Jan 10, 2005 4:34 pm
Location: Bellingham WA

FYI on 3.1.6

Post by nemoby » Fri Dec 30, 2005 1:46 pm

Just upgraded to v3.1.6 from I think v3.1.5 (but not sure on that). Made the install by running the MSI and installing / upgrading over my existing install. I installed both client and server. All worked fine.

I played around a bit with editing a .cs file under the associated .aspx file. This was my main reason for installing the release.

I have all of my VS options set to automatically check out the file etc.

Opening a file that was not checked out allowed me to edit it. It showed with the modified Astrix (*) in the tab of the modified file. But the file was never checked out on the solution and didn't show as a pending checkin. This same behavior repeated itself for all of the other files that I tried.

I then recursively checked out my solution (and all files below it) consisting of about 6 projects (web and class libraries) and then checked everything back in.

This corrected the issue above and now editing a .cs file checks it out. Not sure why?

Thought you might want to know.


Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Fri Dec 30, 2005 1:59 pm

Thanks. Not sure why, either. There's an option in Visual Studio under Tools->Options->Source Control for how to handle a non-checked out item when it is modified. For instance, you can set it to checkout automatically on edit. You might see what your setting is.
Linda Bauer
Technical Support Manager

Posts: 56
Joined: Mon Jan 10, 2005 4:34 pm
Location: Bellingham WA

Post by nemoby » Fri Dec 30, 2005 2:03 pm

It is set to check out automatically. I have not changed any of my settings in that area. Until I checked out the entire solution and then back in, VS wasn't checking out the .cs file when I made edits to it. Normally, there is a slight pause (1/2 second or so) when I type the first key making a change to a file. I assume that it is getting checked out during this pause.

In my case, there was no delay. The file wasn't checked out for me and I am assuming there was no activity to or from the Vault server.

This might be a VS issue or some type of sync issue with VS and Vault?

Seems to work fine now.


Posts: 145
Joined: Wed Feb 18, 2004 10:51 am
Location: Santa Ana, CA, USA

Post by gmagana » Fri Dec 30, 2005 3:12 pm

To add a note, I think VS2005 has several bugs related to version control, one is that VS2005 checks out a file but does not let you know about it (ie, the icon next to the file does not change). Sometimes you can edit the file and then VS is surprised that the file contents changed, so it spews out error messages.

I have been able to partially compensate for VS bugs by enabling the "Source Control" toolbar in the IDE and then clicking the "Refresh Status" button on that toolbar when I suspect VS has messed up its own source control status (ie, by checking out a file and the forgetting it checked it out).

Try that button, for me at least it puts the right icons by the checked out files, and it gives VS a chance to realize which files are checked out.
gabriel magana-gonzalez

Post Reply