Vault web access with sharepoint

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
Posts: 27
Joined: Wed Mar 08, 2006 4:22 am

Vault web access with sharepoint

Post by matt_stephens » Tue Mar 18, 2008 12:03 pm

We upgraded to 4.1 a week or so ago and had some issues with the install because we are using sharepoint on the same default web site in IIS.

Initially it was the handlers that were not set right which seems to be common for us when upgrading but since you now require .NET2 it was slightly different.

We made sure that handlers were working for aspx, asmx and WebResource.axd and this seemed to be good for running the admin part of the site and our client software is working great.

We rarely use the web based access to the source control database but it appears as though we are missing something because all we see is the Source Code Control tab but nothing underneath, despite there being several repositories we'd expect to see.

Any ideas what might be wrong with our setup? or any help on what log files etc. to check to see what is going on.

By the way, i believe we have Gold Support but when i tried to associate the id i was given with my forum user it failed.

Thanks for your help


Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear

Post by Beth » Wed Mar 19, 2008 11:58 am

Can you check in your Vault Server Log for any errors associated with attempting to access the web client?

This is what we normally recommend for running with SharePoint: Installing Vault on the same server as Sharepoint.

Posts: 27
Joined: Wed Mar 08, 2006 4:22 am

Post by matt_stephens » Mon Mar 31, 2008 8:30 am

I set the server to use debug level logging but am not getting any more interesting logfile data. The admin part of the website works fine but the Source Code Control tab is just an empty page as you can see in the attachments.

Interestingly i also tried accessing a link from fogbugz to one of our files and with that direct link the source code control tab is working ok again i added an attachment that shows this - all the links from this page also work as you'd expect so it seems as if it's something on the default Source Control tab that is having trouble.

The logfile gives this info when i started up (i replaced some of the reverse dns lookup stuff with 'username'):

System Started
Cache Level = 1
DataBase Buffer Size (KB) = 256
LogFile Path = C:\WINDOWS\Temp\sgvault
Log Level = Debug
Archive Log = Weekly
ReverseDNS Lookup = True
Maximum HTTP Request Length = 102400
Overwrite Log on Startup = False
Session Timeout = 4320
SGVault Working Directory = C:\WINDOWS\Temp
SGVault Server URL =
Identity = MKSRGA\vault
----31/03/2008 15:04:34 --()-- Beginning SQL transaction 32347029
----31/03/2008 15:04:34 --()-- SQL transaction 32347029 successfully committed.
----31/03/2008 15:04:34 --()-- Beginning SQL transaction 22687807
----31/03/2008 15:04:34 --()-- SQL transaction 22687807 successfully committed.
----31/03/2008 15:04:46 username--SSL Enabled Beginning SQL transaction 40256670
----31/03/2008 15:04:47 username--SSL Enabled SQL transaction 40256670 successfully committed.
----31/03/2008 15:04:47 username--SSL Enabled Login
Shows the source code control tab is empty after logging on
scc.jpg (48.87 KiB) Viewed 1502 times
Shows admin tab functioning ok
admin1.jpg (70.87 KiB) Viewed 1502 times
Shows admin tab functioning ok
admin2.jpg (76.71 KiB) Viewed 1502 times
Shows a link from fogbugz to the SCC data working properly
scc-fb1.jpg (80.82 KiB) Viewed 1502 times

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear

Post by Beth » Mon Mar 31, 2008 9:34 am

After trying to recreate this unsuccessfully on my servers, the only thing that comes to mind for me would be a .NET problem. At a convenient time for you, you could try either uninstalling and reinstalling the .NET framework or perform a repair install on it.

Here's what I usually do.
1) Open command prompt and change directories to C:\Windows\Microsoft.NET\framework 2.0. Then run the command aspnet_regiis -u. When that completes run aspnet_regiis -i.

2) Under Add/Remove programs, you can select 'change' for the 2.0 .NET framework and perform a repair install. I had a couple of users who had to download the 2.0 .NET framework again from Microsoft and use that to perform the repair install.

After trying one or both of these, check to see if the issue clears up.

Post Reply