Can't check in files

Moderator: SourceGear

Posts: 52
Joined: Wed Mar 30, 2011 4:15 pm
PostPosted: Wed Apr 13, 2016 4:02 pm
Suddenly today, I cannot check in changes to existing files. I can check in new files; I can delete files from the project. But I cannot check out a file, change it, and check it in.

Just installed the version 8 CPC onto a machine that hasn't had Vault on it. Running Java 1.8.0_77. No problem getting it set up and talking to the version 8 server.

I got the latest version of my project files with no difficulty. Added a new file with no difficulty. But when I checked that file out and modified it, I can't check it in. I select "check in", add a comment, and hit "OK". Nothing happens. Status still says "edited". Because the project has a shadow directory on the server, I'm able to see that the changes have not been made on the server.

Tried right-clicking on the file in the "pending change set" pane and selected "commit selected operations". Still doesn't work.

Tried telling it I wanted to keep it checked out and also not telling it to keep it checked out. No difference.

If I delete the file from the project, I can re-add it, but I lose my history.

If I undo checkout on that machine, go to another machine, check out the file, make the same changes to the file, and try to check it in, it doesn't work there either.

Now, here's the potential twist: When I configured the new machine, I thought I was logging in as a different user. Turns out I was using the same account as I use on a different machine. When I log out of that account, log into a different account, check out the file, make the changes, and check it in, everything works.

So what have I screwed up on my original account that makes it so it can't check in changes? Or are you as confused as I am at this point?

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Apr 13, 2016 4:08 pm
What is the OS of the machine you use the CPC with?

You might try renaming your client-side cache. When you login to the machine as a different user, the cache is under that other user account, so it's not the same as the original.
Beth Kieler
SourceGear Technical Support

Posts: 52
Joined: Wed Mar 30, 2011 4:15 pm
PostPosted: Fri Apr 15, 2016 1:30 pm
So to recap: I normally use Vault CPC on my MacBook. The other day I installed it on a Mac Pro and thought I was logging into my second user account but actually was logging into the same account I use on my MacBook. For reasons beyond my comprehension, that made it so I could add and delete files from my projects in Vault, but could not check in my changes (this is from the Mac Pro).

The solution was to completely delete the project on the Mac Pro, actually log in as my alternative self so that I was using a different user account than my MacBook, and re-get the project from the server. Now the Mac Pro is working fine.

Today I'm back on my MacBook and again, I can check out but not check in any files using the same account I've always used on my MacBook. Why anything I did on an entirely different computer would have any effect on my MacBook is beyond me to understand.

I have deleted the entire cache folder (I deleted the repository folder - the one named with a GUID), launched the CPC, set the working folder to point to my existing folder, did a "Get Latest Version" to "re-establish a baseline", resolved the merge status on my one changed file, and I cannot check it in. I can undo checkout and check it out again, but I cannot check it in.

The only thing I have not does is restarted IIS because I don't want to restart every website running on that server and I fail to understand why it would make any difference.

Running version 8 still because 9 requires that I bring the company to a stop and have everyone install new clients.

Posts: 52
Joined: Wed Mar 30, 2011 4:15 pm
PostPosted: Fri Apr 15, 2016 1:41 pm
After I sent this I realized I could restart IIS just for my Vault subdomain, so I did that. I repeated the whole process of deleting the client-side cache and whatnot. No difference in behavior.

Posts: 52
Joined: Wed Mar 30, 2011 4:15 pm
PostPosted: Fri Apr 15, 2016 1:51 pm
Just repeated the process to be sure.

Undo my checkout of the file in question. It goes to Renegade status.

Exit the Vault CPC.

Delete the entire Repository cache (the folder named with a GUID).

Go to the server and restart IIS for my vault subdomain.

Run the Vault CPC.

Log in.

Get Latest Version of my project with "Do not overwrite/Merge later".

Check out my file. It is now in "Needs Merge" status.

Use diff to verify the differences are what I expect, then resolve the merge status. File now shows edited.

Right click, choose Check In, write a brief comment, press OK to check it in.

Nothing changes, nothing happens. No message in the Messages pane, nothing.

I am unable to do anything this afternoon but hit refresh on my browser waiting for an answer.

Posts: 52
Joined: Wed Mar 30, 2011 4:15 pm
PostPosted: Sat Apr 16, 2016 8:35 am
Thanks for the help on the phone.

Late last night I deleted every trace of Vault from my MacBook, including all the sgbak folders in every project, cache folders, data folders, and the application itself. Then I restarted IIS on my Vault subdomain, downloaded a fresh copy of the CPC, and installed. Same results as before. This would indicate to me that the problem is somehow on the server.

This morning I deactivated the user account in question, created a new user, and was able to check in changed files. This will let me get the work done this weekend that I couldn't do on Friday. This might further confirm that it is the user account and whatever data is stored on the server related to the user account that is causing the problem.

A couple of observations after going through this process:

Vault CPC keeps its settings in ~/Library/SourceGear/Vault_1/com.sourcegear.vault.guiclient. It also keeps its cache files there. But its cache files seem to contain status information. That is, if you delete the cache, you would expect the program to be less efficient until the cache gets re-established. But with Vault, when you delete the cache you lose working folder assignments and other information that has to be re-entered before you can continue.

SourceGear is essentially duplicating and blending the function of several standard Library folders in its dedicated folder. It should be putting non-cache data files in ~/Library/Application Support/com.sourcegear.vault-cpc. It should be putting its cache files in ~/Library/Caches/com.sourcegear.vault-cpc. And it should be putting user settings in ~/Library/Preferences/com.sourcegear.vault-cpc.

On top of this, SourceGear keeps certain settings in an XML file inside the application bundle. Yikes. These should be stored in user preferences and kept in ~/Library/Preferences where the belong.

Needless to say, you certainly can create a folder inside ~/Library and do whatever you want with it, but as we found yesterday while working through this on the phone, it was difficult to keep track of where these various files were at because they weren't in the places where they arguably belong.

Thanks again for your help. Hope these comments help you identify what is going on. I'll look into upgrading to 9 on Monday.

Posts: 52
Joined: Wed Mar 30, 2011 4:15 pm
PostPosted: Sat Apr 16, 2016 10:24 am
Yeah, I take that all back. It's doing it again with the new user ID and I never used the new user on any other machines. So something is broken in the client. Or perhaps it's OS X 10.11.3, but I have been running under 10.11.3 for a long time. And it worked for a while and stopped working after an hour or so.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Mon Apr 18, 2016 10:40 am
As an update to this thread, the user and I met offline. One identified problem appeared to have been an older Vault server that was still available at the same hostname as what was in the hostheader.
Beth Kieler
SourceGear Technical Support

Return to Vault Standard CPC (Cross Platform Client)

Who is online

Users browsing this forum: No registered users and 1 guest