Vault CPC 10.0.1 (and earlier) sys requirements

Moderator: SourceGear


Posts: 3541
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Thu Nov 02, 2017 8:48 am
It appears that starting with Java 8 Update 152 / Java 9 / Java 10, the JDK changed some of the dependencies in the packages and/or classes shipped with the JDK. So, at this time, Vault CPC 10.0.1 and earlier versions will only work with Java 7/Java 8 Update 151.

If you do not require these versions of Java, uninstall any releases, and download and install the Java 8 Update 151 JDK.

However, if you still require Java 8 Update 152 (or higher) and/or Java 9, Java 10, you can edit the vault-cpc.ini file, add the following lines BEFORE the "-data" line:

...
--launcher.XXMaxPermSize
128m
-vm
/path/to/java/8_update151/jdk/bin

-data
...

For example, the vault-cpc.ini ( found in the vault-cpc.app bundle in the ./Contents/MacOS/vault-cpc.ini, so you'll have to use a terminal or 'Show Package Contents' on the vault-cpc.app to access the file ) on a Mac is as follows:

...
--launcher.XXMaxPermSize
128m
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_151.jdk/Contents/Home/bin
-data
...


Please note, the instructions above are for Vault Standard, but the instructions for Vault Professional are essentially the same with a couple of exceptions. Instead of vault-cpc.ini, the file name is vaultpro-cpc.ini, and the Mac OS X app bundle is named vaultpro-cpc.app.

The Java 8 Update 151 JDK can be found on this page - http://www.oracle.com/technetwork/java/ ... 77648.html
Jeff Clausius
SourceGear

Return to Vault Standard CPC (Cross Platform Client)

Who is online

Users browsing this forum: No registered users and 1 guest