Troubleshooting "Unable to connect to server"

A collection of information about Vault, including solutions to common problems.

Moderator: SourceGear

Post Reply
Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear

Troubleshooting "Unable to connect to server"

Post by jeremy_sg » Wed Apr 07, 2004 9:13 am

There are numerous reasons why the client could give this error when attempting to log in to the Vault server. In order to help narrow down the cause of the problem, follow this procedure:

<li><b>Try to load the serverInstall.html page.</b>
In a web browser, load the page http://VAULTSERVER/VaultService/, where VAULTSERVER is the hostname that you entered into the Vault client's login dialog. If your server is properly configured, you should see a page like this:


If you do not see this page, then the Web Server is not accessible from the client that you are connecting from. Verify that IIS is running. Try repeating this test from the server machine connecting to http://localhost/VaultService

<li><b>Attempt to load the Vault Service page using Internet Explorer.</b>
Open a web browser to the page http://VAULTSERVER/VaultService/VaultService.asmx where VAULTSERVER is the hostname that you entered into the Vault client's login dialog. If your server is properly configured, you should see a page like this:


If you see a message like this:

Code: Select all

<%@ WebService Language="c#" Codebehind="VaultService.asmx.cs" Class="VaultService.VaultService" %>
then your IIS and .Net settings are not correct. There is a Vault KB article for this error at

If you see an HTTP error with status code 404 or 405 and you are server is on a Windows 2003 server, then you should verify that your IIS settings are correct. There is a Vault KB article for these errors at

<li><b>Verify proxy settings are correct.</b>
If you use a proxy, or your network requires a proxy, you might need to configure Vault in order to connect to the server. You can check your current proxy settings by loading Control Panel -> Internet Options -> Connections tab -> LAN Settings. A dialog that looks like this should come up


By default, Vault will use any proxy specified manually in the lower area of this dialog. If you do not wish to use the proxy for Vault traffic (in the case of non-essential proxies like AdSubtract), you can put the Vault server address in the list of exceptions by clicking the Advanced button.

Due to a flaw in the .Net Framework, Vault can not use Automatic configuration to determine the proxy to use. If your network uses Automatic configuration, then you must configure the location of your proxy in the file C:\Program Files\Sourcegear\Vault Client\VaultGUIClient.exe.config (available in Vault version 2.0). Edit the file and replace the lines

Code: Select all

<proxy usesystemdefault="true"/>
<!--<proxy usesystemdefault="false" proxyaddress="http://proxyhost:proxyport" bypassonlocal="false"/> -->
changing them to

Code: Select all

<!--<proxy usesystemdefault="true"/>-->
<proxy usesystemdefault="false" proxyaddress="http://proxyhost:proxyport" bypassonlocal="false"/> 
substituting proxyhost and proxyport for the correct values for your network. Note that this change can also be made in the machine.config file on the client machine as well.

<li><b>Verify that the Vault Server can connect to SQLSever.</b>

If you get an error message with the error code FailDBConn, then the Vault server could not contact the SQLServer. You should look at the server's log file, which is located in c:\windows\temp\sgvault\sgvault.log by default.

The most common causes of failure to connect to the database are:

<li> The user that Vault is connecting with does not have access to the SQL Server, or to the sgvault database.
<li> SQLServer is on a different machine, but the Vault service has not been set up to use impersontation. For more information on impersonation, see ... torial.asp
<li>The Vault server does not have the correct SQL components installed. See

Internet options proxy dialog
proxy.gif (54.54 KiB) Viewed 26132 times
A correctly configured VaultService.asmx page
vaultservice.gif (76.77 KiB) Viewed 26138 times
serverInstall.html page
serverinstall.gif (86.89 KiB) Viewed 26140 times

Post Reply