Login issue with VB 6 on Windows 2003 Server

A collection of information about Vault, including solutions to common problems.

Moderator: SourceGear


Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Tue Sep 26, 2006 8:08 am
If Vault integration with Visual Basic 6 is used on Windows 2003, you may encounter a problem with the Vault login dialog. Due to a bug in the .NET Framework, the Vault login dialog does not respond to mouse clicks, nor can you type in the password box. Tabbing through commands does work.

This bug is related to some changes Microsoft made to a build of .NET 1.1 SP1 for Windows 2003 Server. The dialog works properly if the the .NET 2.0 framework is loaded for IDE integration.

Here's the workaround:

1. If it's not already there, install .NET 2.0 on the Windows Server 2003 machine.

2. make a copy of the VaultGUIClient.exe.config (in the Vault GUI Client directory) and rename it "VB6.exe.config."

Copy the VB6.exe.config into the same directory as VB6.exe and enter runtime information so that the first part of the file looks like this:

Code: Select all
<?xml version="1.0"?>
<configuration>
<startup>
<supportedRuntime version="v2.0.50727"/>
<requiredRuntime version="v2.0.50727" safemode="true"/>
</startup>
</configuration>


You should now be able to type in and use the mouse in the connection dialog.
Linda Bauer
SourceGear
Technical Support Manager

Return to Knowledge Base (Vault)

Who is online

Users browsing this forum: No registered users and 0 guests

cron