Troubles after Upgrade to 3.52

This forum is now locked, since Gold Support is no longer offered.

Moderator: SourceGear

Locked
Tri
Posts: 288
Joined: Wed Dec 22, 2004 11:10 am

Troubles after Upgrade to 3.52

Post by Tri » Thu Aug 16, 2007 9:24 am

Hi,

We have upgraded our Vault Server from 3.16 to 3.52 last week. We are now experiencing some issues regarding labelling and branching.

Issue 1: Folder labels lost: A new label is applied to a project folder "myApp". Check all labels are shown OK. Then the folder is branched. The branch was successful but the "myApp" folder lost ALL labels except the last one. Show History of any FILE below "myApp" still list the previous labels.

Edit #2: history on any FILE shows previous labels. But "Show Label" of the same file only show the labels created AFTER the issue. Why does "Show Label" of the file see less labels than "Show History"

On the "myApp" folder and any sub-folders below. Show History and Show Labels only list the labels created since 2007-08-15 2:00 PM (where we suppose the issue occurred after the branch).

Issue 2: By trying to reproduce the error. I labelled and branched a small test folder. The branching operation failed. The Vault Server logged the following error:

System.Data.SqlClient.SqlException: XML parsing error: A semi colon character was expected.
at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream)
at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior)
at VaultServiceSQL.VaultSqlSCC.BranchFolder(VaultSqlConn conn, String strSessionID, Int32 nRepID, Hashtable htSharedItems, HybridDictionary htTxModifiedItems, Int64 nTxID, Int32 nTxItem, Byte nTxType, VaultDateTime vdTxBegin, String strItemPath, String strNewBranchName, String strXml, BranchingModTime bmt, VaultFolder vfRoot, String strTxComment, Int32& nCopiedSecurityFolderRights, VaultFolder& vfOut) at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream)
at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior)
at VaultServiceSQL.VaultSqlSCC.BranchFolder(VaultSqlConn conn, String strSessionID, Int32 nRepID, Hashtable htSharedItems, HybridDictionary htTxModifiedItems, Int64 nTxID, Int32 nTxItem, Byte nTxType, VaultDateTime vdTxBegin, String strItemPath, String strNewBranchName, String strXml, BranchingModTime bmt, VaultFolder vfRoot, String strTxComment, Int32& nCopiedSecurityFolderRights, VaultFolder& vfOut)

FYI, The Server Update was made by installing 3.52 on top of 3.16. Could it be possible that the 3.52 installer failed to clean up obsolete its own resources? Similar to the Admin Tool connection error we had. Because we needed to clean up manually the registry (http://support.sourcegear.com/viewtopic.php?t=8391) in order to make the Admin Tool 3.52 work.

Issue #1 is pretty serious, hope you can help to recover the previous labels.
Last edited by Tri on Thu Aug 16, 2007 10:42 am, edited 2 times in total.

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Thu Aug 16, 2007 9:37 am

Is there an ampersand in the folder, label or any file names? The error you are getting indicates a problem handling certain characters.

We probably will need to get a copy of your database to determine what the problem is. Email support at SourceGear.com ATTN Linda and we'll take the next steps.
Linda Bauer
SourceGear
Technical Support Manager

Tri
Posts: 288
Joined: Wed Dec 22, 2004 11:10 am

Post by Tri » Thu Aug 16, 2007 9:48 am

Hi Linda,

I have just edited Issue #1. The folder lost the previous labels. Not the files.

As for Issue #2, the source folder name is _Deployment and the branched folder name is _Deployment_ToDELETE

There are only 3 small test files inside the _Deployment folder, their names contains letter, numbers, dash underscore, no space. When I reproduce Issue #1 and #2 on a test server, there is no error.

The Test "server" is my own laptop. It has 3.16 and updated to 3.52. The difference is that its sgvauld DB only contains a dozen of files. I use it to simulate complicate operations or to reproduce error scenarios encountered on our production server.

Tri
Posts: 288
Joined: Wed Dec 22, 2004 11:10 am

Post by Tri » Thu Aug 16, 2007 10:47 am

Please re-read the original post. Issue #1 is updated with more accurate details.

Issue 2 is rather mysterious, I just redid a branch of a real project (used in Issue 1) and the branch was successful. This project has many thousands files and a lot of folders, many of them have even weirder characters in their names than the small sample I used for the test of Issue #2.

Tri
Posts: 288
Joined: Wed Dec 22, 2004 11:10 am

Post by Tri » Thu Aug 16, 2007 2:53 pm

Issue #3: When doing "Show History" of a file. The Parent folder name is not displayed with its fullname. Only the last letter is visible.
Attachments
FileHistory_MissingFullNameParentFolder.png
FileHistory_MissingFullNameParentFolder.png (9.57 KiB) Viewed 14513 times

Tri
Posts: 288
Joined: Wed Dec 22, 2004 11:10 am

Post by Tri » Thu Aug 16, 2007 3:03 pm

Here is some screenshots to illustrate Issue #1 described in the original post. Please notice that the Show Label screen doesn't show the same list of labels than the Show History screen.
Attachments
File_ShowHistory.png
File_ShowHistory.png (29.52 KiB) Viewed 14510 times
File_ShowLabel.png
File_ShowLabel.png (6.5 KiB) Viewed 14510 times

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Thu Aug 16, 2007 3:48 pm

Regarding the branch/label issue, I just want to be clear, if you have branched MyApp to, let's say MyAppBranch, you are viewing history or labels on MyApp, is that right?

Or are you viewing the history/labels on the branch, MyAppBranch?
Linda Bauer
SourceGear
Technical Support Manager

Tri
Posts: 288
Joined: Wed Dec 22, 2004 11:10 am

Post by Tri » Thu Aug 16, 2007 3:53 pm

Show Label is performed on MyApp (the source Folder).

Tri
Posts: 288
Joined: Wed Dec 22, 2004 11:10 am

Post by Tri » Thu Aug 16, 2007 4:18 pm

Here is the file history from the Branched Folder. Please notice the line with Version 17 (Branch From Share, in FileHistory_FromBranch.png).

The person who create the branch. First created a shared folder and then created a branch from this shared folder. Is there any adverse effect compared to a branch folder created directly (without creating first a shared folder)?

BTW, previous branches created before v3.52 using this "habit" (shared + branch) didn't exhibit the loss of labels. As you can see in the "FileHistory_FromBranch_2-4_HavingLabels.png" screenshot. This is the file of the previous branch created in June 2007. The file history (taken from the branched folder) shows all the labels. The same which has been branched yesterday (FileHistory_FromBranch.png) has lost all labels in its history.
Attachments
FileHistory_FromBranch_2-4_HavingLabels.png
FileHistory_FromBranch_2-4_HavingLabels.png (24.96 KiB) Viewed 14491 times
FileHistory_FromBranch.png
FileHistory_FromBranch.png (22.54 KiB) Viewed 14493 times

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Fri Aug 17, 2007 1:00 pm

I did find a bug logged regarding branches and labels -- this bug is still open, plus there were some branch changes in Vault 3.5.x.

I'd like specific steps to reproduce what you are seeing, so we can determine if this is caused by changes in 3.5.x, or if there might be a problem with your database.

Thanks.
Linda Bauer
SourceGear
Technical Support Manager

Tri
Posts: 288
Joined: Wed Dec 22, 2004 11:10 am

Post by Tri » Fri Aug 17, 2007 4:01 pm

Thanks for following up. We really hope you can find a fix soon. If there is a problem in the DB is it before or after the branching operation? In anyway, the update from 3.16 to 3.52 went successfully two weeks ago.

The Steps which were done:

1. Label current version folder. let's call myApp project.
Verification on history and show labels is OK.

2. Create a new folder outside of MyApp which will host the branch. The folder name contains symbols. Ex: "MyApp - v2.5 (Phase1)" (without quotes).

3. Share myApp folder, target folder is "MyApp - 2.5 (Phase1)"

4. Branch myApp folder, sams target folder
(the person who did the branch is used to this routine).

5. myApp and the branch: all folders and files lost their previous labels when using the Show Label command. Only the latest label created in step 1 remain visible (labels created after step 5 do behave normally).

Show History on a file do display the previous labels. However Show History on a folder still lost their previous labels. In addition, all folder history entries earlier than the branch made in Step 4 has their name corrupted (only the last letter of the folder name is displayed). See screenshot on post #5 above.

The label issue, for now seems to be isolated only on the myApp folder.

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Sun Aug 19, 2007 8:38 pm

I was not able to reproduce this. I created a folder (FolderA), added some files, applied some labels, modified files, labeled the folder a couple of times. etc.

Then I created the My App - 2.5 (Phase 1) folder, branched FolderA (named it FolderAbranch) then shared Folder A into the My App - 2.5 (Phase 1) directory.

The branch showed no labels, but this is a known issue. FolderA and its share both had history and labels.

This is most likely specific to your database, especially if you can't reproduce it with other folders.

It's hard to say what happened until we have a chance to examine the database. we don't need the source code stored there -- just the database structure. I'll contact you offline about getting a copy.
Linda Bauer
SourceGear
Technical Support Manager

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Wed Sep 12, 2007 2:46 pm

Tri contacted us offline and we think we have some idea of why the history and labels were lost on $/MyProject123/Code.

Normally, if you branch $/MyApp to create $/MyAppbranch, $/MyApp retains all folder history and labels. $/MyAppBranch just has the branch operation in folder history. File history and file labels are preserved in $/MyAppBranch, though.

If $/MyApp is shared to $/MyAppShare, and you do a branch operation on $/MyAppShare, then $/MyAppShare becomes a branch and loses folder history. File history and file labels are retained. $/MyApp retains all folder and file history.

However -- If $/MyApp is shared to $/MyAppShare, and you do a branch operation on $/MyApp, then $/MyApp becomes a branch and loses folder history. File history and file labels are retained. $/MyAppShare should retain folder history.

Your repository history shows Branch from share on $/MyProject123/Code at 8/15/07 at 1:07:29 p.m. This means Code had been shared, then a Branch operation on Code broke the share, causing $/MyProject123/Code to lose its folder history and labels.

Unfortunately, there's nothing we can to to restore the labels. If you need the contents of these labels, you can probably retrieve the version of the tree at the time of the label by doing a history query on Folder History by Version on the parent folder.
Linda Bauer
SourceGear
Technical Support Manager

Locked