Login Failed with 4.1 and 64bit 2003 server - FailDBConn

If you are having a problem using Vault, post a message here.

Moderator: SourceGear


Posts: 14
Joined: Wed Mar 05, 2008 2:51 pm
PostPosted: Wed Mar 05, 2008 3:24 pm
Having trouble logging in as "admin". It returns the following msg:

Login Failed: The Vault Server could not establish a connection to the database. Please check the server's log for detailed information. (FailDBConn)

The install went fine with no issues and the login screen comes up, but I can't login.

The sgvault.log says:
----3/5/2008 3:10:22 PM admin--SourceGear(127.0.0.1)--SSL Disabled Could not load connect string. There is probably an error with the encrypted password for the sgvaultuser database user. Contact technical support at http://support.sourcegear.com
----3/5/2008 3:10:22 PM admin--SourceGear(127.0.0.1)--SSL Disabled Vault Failed to establish a connection to the database.
----3/5/2008 3:10:28 PM admin--SourceGear(127.0.0.1)--SSL Disabled Could not load connect string. There is probably an error with the encrypted password for the sgvaultuser database user. Contact technical support at http://support.sourcegear.com
----3/5/2008 3:10:28 PM admin--SourceGear(127.0.0.1)--SSL Disabled Vault Failed to establish a connection to the database.

John

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Mar 05, 2008 4:34 pm
Can I have you uninstall and reinstall, but use Windows authentication instead of SQL authentication on the database connection? Then let me know the results.

Posts: 490
Joined: Wed Jan 14, 2004 10:22 am
Location: SourceGear
PostPosted: Wed Mar 05, 2008 5:00 pm
OK, it seems that there is a problem with SQL auth and 64-bit machines.

The Crypto Keys in the registry SQL auth needs to decrypt the password are being put in the wrong hive for some reason.

There are a couple of ways you can get around this:

- Export the SourceGear\Vault (or Fortress) Server registry key from the 64 bit hive and import it into the WOW6432 hive. To do this open RegEdit and export HKLM\Software\SourceGear\Vault Server to a .reg file, open the .reg file in notepad, change the registry paths to the wow6432node then and import it to HKLM\Software\WOW6432Node\SourceGear\Vault Server (or you can just copy and paste the values from one place to the other).

- Uninstall and Re-install using Windows Authentication.

We will have this fixed in the next release. Sorry for the inconvenience.
Mary Jo Skrobul
SourceGear

Posts: 14
Joined: Wed Mar 05, 2008 2:51 pm
PostPosted: Wed Mar 05, 2008 5:44 pm
I tried with Windows Authentication and that did not work. That is most likely because I'm on a workgroup instead of a domain.

But the registry key trick did work!!

Thanks!

John Lehew

P.S. One other thing I had to do to get 64 bit working is to run aspnet_regiis -i for BOTH 32bit AND 64bit then go to inetmgr and enable both the 32bit and 64bit "Web Service Extensions".

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Wed Mar 12, 2008 4:16 pm
Thanks for the follow up. Happy to hear you are working.
PostPosted: Tue Apr 01, 2008 6:41 pm
After enabling ASP.NET with information from here
[url]http://support.microsoft.com/kb/894435[/url]
and then enabling the ASP 2.0.5 Web Service Extension in IIS I was able to see the logon page but could not logon with Admin user

I couldn't see an admin user in the databases either so thought install had got messed up. Install didn't crash but log showed permissions errors when the installer was trying to apply permissions for the machinename\aspnet user.
May have been because ASP.NET wasn't enabled in 32 bit mode prior to install.

Eventually found this post on the forum, moved the Registry key.
I still couldn't logon with Admin user.

Did an uninstall and reinstall which seemed to have no permissions problems this time

Then still got told the Admin user logon was causing a database connection problem.

I had to re-copy the Registry key - it changes every time you do an install - and was finally able to logon with the Admin user!!

>>> Comment for SG users -- Ring Source Gear the're staff on the phone are awesome <<<

>>> Comment for SG staff -- you guys rock, but please oh please could you do some screen capture install documentation or videos so that it's a little more obvious what things mean. It would also mean you get less phone calls. <<<

>>> General comment - Please sort out a way for the database name to be set by the intstaller, business risk for large SG Vault installs is a big deal and upgrading in place isn't always an option <<

Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Tue Apr 01, 2008 8:14 pm
We're currently working on a Vault 4.x installation guide.
Linda Bauer
SourceGear
Technical Support Manager

Return to Support (Vault)

Who is online

Users browsing this forum: Exabot [Bot] and 11 guests