Unspecified error in 4.2 Client with VS 2008 under Vista

If you are having a problem using SourceOffSite, post a message here.

Moderator: SourceGear

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by jclausius » Tue Sep 09, 2008 3:17 pm

Brian:

I'll need to recreate this setup and see what kind of problems I encounter using the link you posted. I'll report back when I have the results sometime tomorrow.
Jeff Clausius
SourceGear

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by BrianDrab » Tue Sep 09, 2008 3:36 pm

I look forward to the response. Thank you.
Brian C Drab

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by jclausius » Wed Sep 10, 2008 9:30 am

Brian:

I created a blank solution, and added two projects within Visual Studio 2008. I placed the solution in a the following folder - "G:\Users\jclausius\Documents\Visual Studio 2008\projects\dev\vss\develop\vs2008\Solution2008". Next I added the entire solution (and sub projects) to Source Control using SourceOffSite.

Next, I added a mykey.snk file from the G:\Users\jclausius\Documents\Visual Studio 2008\projects\dev\vss\develop\ directory (which I created by hand). Visual Studio checked out the project file, but it also seemed to "copy" the file into my Project1\ directory. I closed Visual Studio, and deleted the mykey.snk file from Project1\. Next I edited Project1's project file, and changed the mykey.snk to "..\..\..\Docs\mykey.snk", saved the file and re-opened the Solution within VS 2008. This time around, Project1 had the key file listed but with a "small arrow" in the left corner indicating the file was not a part of the project's path. Finally, I highlighted the mykey.snk file from within the Solution Explorer, and from the menu, chose File -> Source Control -> Exclude mykey.snk from Source Control. Saved everything and checked the project back into SOS.

This seems like a setup you were trying to create from within your post. Would this work for you?
Jeff Clausius
SourceGear

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by BrianDrab » Wed Sep 10, 2008 11:11 am

OK, now unbind the solution and projects and rebind them. Does it work through Source Offsite?
Brian C Drab

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by jclausius » Wed Sep 10, 2008 12:17 pm

I'll check. Is there a reason you are binding and then unbinding?
Jeff Clausius
SourceGear

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by BrianDrab » Wed Sep 10, 2008 12:28 pm

It's almost always needed when converting our projects from a previous Visual Studio version to a new version. In addition there are times that we may want to change the binding if we move the solution from one project to another within VSS and many other times something quirky happens and the solution is always unbind and rebind. Let me know what you find.
Brian C Drab

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by jclausius » Wed Sep 10, 2008 12:32 pm

OK. I received an error similar to the original posting:

Error: Unspecified error
File: vsee\pkgs\vssprovider\cmsscciabstractionlayer.cpp
Line number:5892
Attachments
bind-1.jpg
bind-1.jpg (244.36 KiB) Viewed 12637 times
Jeff Clausius
SourceGear

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by jclausius » Wed Sep 10, 2008 12:43 pm

I'm uncertain exactly what is happening as SOS seems to be doing the right thing. VS is asking for a version of a file under version control, but SOS reports the file is not under SOS's control.

This does not seem to be isolated to SOS - see http://social.msdn.microsoft.com/forums ... 5d74cb819/ for an example of this same error with Visual SourceSafe.

As in this article, I tried an open from Source Control and this *DID* open the project. I told it to use the binding, and the project finally opened. That is one possible work-around. In any regards, I'll log a bug and we'll check to see exactly what behavior *should* be expected in this case and if applicable, have a fix in the next version of SOS.

Thanks.
Jeff Clausius
SourceGear

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by BrianDrab » Wed Sep 10, 2008 1:03 pm

I tried to click on the link that you provided however it doesn't work. Maybe you have to be a member of social.msdn.microsoft.com or something. In any event the binding works fine when using Visual SourceSafe 2005 so if it was a bug in their product it no longer is.

Thanks for taking the time to look into this and I look forward to the fix.
Brian C Drab

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by jclausius » Wed Sep 10, 2008 2:57 pm

This link might work - http://www.the3factory.com/post/2008/04 ... ercpp.aspx

When we start working on the IDE client for the next version, we'll investigate to see what exactly what is going on.
Jeff Clausius
SourceGear

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by BrianDrab » Wed Sep 10, 2008 3:03 pm

Indeed it did, thanks. In this instance the user appears to have been mixing sourcesafe options using the VSS IDE as well as the Visual Studio IDE so I could see this happening. In our instance we are properly using only the Visual Studio IDE.
Brian C Drab

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by jclausius » Thu Sep 11, 2008 12:46 pm

Yes, but the error is related. In any case, we'll investigate the issue. Thanks for the report.
Jeff Clausius
SourceGear

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by BrianDrab » Tue Nov 17, 2009 1:36 am

Can you verify for me that this is now fixed in the current version? Before I upgrade I would like to know.

Thanks.
Brian C Drab

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by Beth » Wed Nov 18, 2009 4:47 pm

SOS was tested with VS 2008 and Vista and Windows 7, so I think this should be fine now. I'll do a little more checking to see about this specific case.

If the project you are working with is a Setup project, then let me know. That might be a special case separate from all other project types.
Beth Kieler
SourceGear Technical Support

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Unspecified error in 4.2 Client with VS 2008 under Vista

Post by BrianDrab » Thu Apr 08, 2010 10:08 pm

I never heard back from you but I'm happy to report that this issue is resolved with the current 5.0.2 client. We no longer have to use Visual Source Safe 2005 for this scenario.
Brian C Drab

Post Reply