SOS 5 Explorer Get from _underscore folder

If you are having a problem using SourceOffSite, post a message here.

Moderator: SourceGear

Post Reply
Jared Sullivan
Posts: 81
Joined: Sun Aug 06, 2006 12:51 am

SOS 5 Explorer Get from _underscore folder

Post by Jared Sullivan » Mon Nov 02, 2009 4:15 pm

Hi,

SOS 5 just won't get my scripts (.SQL files -recursivley) from my folder called (_scripts), remotley. Steps to reproduce are:

1. Win7 host
2. Win7 remote
3. Add folder called $/project1/_scripts
4. Add some .SQL files to folder
5. Checkout on remote recursivley using SOS 5 explorer using right click on _folder

See pic attached. No errors client/server side.
Attachments
get.png
get.png (171.15 KiB) Viewed 7749 times

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Re: SOS 5 Explorer Get from _underscore folder

Post by Beth » Mon Nov 02, 2009 6:07 pm

I've confirmed the behavior you are seeing. I will get a bug logged.

In the meantime, if you select all the files and then Get Latest, they will all be pulled down.

F: 15053
Beth Kieler
SourceGear Technical Support

jclausius
Posts: 3663
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: SOS 5 Explorer Get from _underscore folder

Post by jclausius » Tue Nov 03, 2009 8:35 am

Jared:

Does a recursive get on "$/Hist/App/My Couriers" Get the files? There seems to be a problem when the GET is on the folder with an underscore, but not on any of the parent folders. It doesn't make a lot of sense because a GET on any folder (regardless of name) executes the same code. In any case, we'll find and fix this problem.

Thanks again for the report.
Jeff Clausius
SourceGear

jclausius
Posts: 3663
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: SOS 5 Explorer Get from _underscore folder

Post by jclausius » Tue Nov 03, 2009 9:08 am

OK. It looks as if there is a problem with GET where the files in the folder are missing. If you create some 0 byte files w/ the same name (changing the status to "Unknown") or GET from the "file view" side, the files should be retrieved. The fact the folder has an underscore is irrelevant.

We'll have a patch for this shortly in SOS 5.0.1.
Jeff Clausius
SourceGear

Jared Sullivan
Posts: 81
Joined: Sun Aug 06, 2006 12:51 am

Re: SOS 5 Explorer Get from _underscore folder

Post by Jared Sullivan » Tue Nov 03, 2009 8:31 pm

Yeah, I didn't get notification on your post, however I was just about to post that -- doesn't matter what folder is called only subfoders are pulled down not files directly in root.

"Files directly in root ignored"

Could lead to deploy errors, unlikley. Thanks for 5.0.1.

Jared Sullivan
Posts: 81
Joined: Sun Aug 06, 2006 12:51 am

Re: SOS 5 Explorer Get from _underscore folder

Post by Jared Sullivan » Sun Nov 08, 2009 2:59 pm

Hi,

Do you think I could get a pre-release build. Save me remembering to manually pulls files down when building.

thanks
jared

jclausius
Posts: 3663
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: SOS 5 Explorer Get from _underscore folder

Post by jclausius » Sun Nov 08, 2009 4:50 pm

We're almost done verifying the completed issues. SOS 5.0.1 will be released on Mon. or Tues.
Jeff Clausius
SourceGear

jclausius
Posts: 3663
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: SOS 5 Explorer Get from _underscore folder

Post by jclausius » Tue Nov 10, 2009 8:11 am

We have wrapped up the Q/A cycle for SOS 5.0.1. A download will be available later today.
Jeff Clausius
SourceGear

Post Reply