Response for No Message Sent! - SOS 5.0.1

If you are having a problem using SourceOffSite, post a message here.

Moderator: SourceGear

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Response for No Message Sent! - SOS 5.0.1

Post by BrianDrab » Fri Jan 29, 2010 9:57 am

From: support@sourcegear.com [mailto:support@sourcegear.com]
Sent: Tuesday, December 29, 2009 5:38 PM
To: Brian Drab
Subject: RE: SourceOffSite and VS 2008 {218654}

Hello Brian,

A developer and I are working on the issue you ran into with the file shared between multiple projects. We want to make sure we reproduce this correctly. Currently, I haven't been able to make the same situation happen.

Can you provide more details? Can you confirm that the layout with the shared files is the same in SOS 4.2 and that it worked for you that way?

Were the shares made in VSS or in SOS?
-----------------------------------------------------------------------------------------------
Thanks,
Beth Kieler, MCTS
Technical Support
Brian C Drab

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Response for No Message Sent! - SOS 5.0.1

Post by BrianDrab » Fri Jan 29, 2010 10:00 am

OK, I'm done with testing and here are the results.

With the exception of the "Response for No Message Sent!" message box coming up twice in succession there appears to be no difference between SOS 4.2.0 and 5.0.1. The message doesn't come up on the previous version of SOS. That's probably what prompted the developer to tell me there was issues....because of this difference. In addition, when you unbind the projects and then attempt to re-bind them, the one project that shares those couple of files gets the same message as follows:
Item2.jpg
Item2.jpg (39.73 KiB) Viewed 10169 times


Now I also did this with Visual SourceSafe 2005. When unbinding and re-binding the project with the shared files the following message is given:
Item3.jpg
Item3.jpg (50.78 KiB) Viewed 10169 times


After clicking OK, bound to the parent project as it states in the message box and it worked like a charm. So that appears how Microsoft deals with the shared files issue.

Also see this post. http://support.sourcegear.com/viewtopic ... 2&start=15

Maybe the issue will be resolved by the end of January….it’s similar.

Thank you and have a happy New Year.
Brian C Drab

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Response for No Message Sent! - SOS 5.0.1

Post by BrianDrab » Fri Jan 29, 2010 10:00 am

From: support@sourcegear.com [mailto:support@sourcegear.com]
Sent: Friday, January 15, 2010 10:55 AM
To: Brian Drab
Subject: RE: SourceOffSite and VS 2008 {218654}

Hello Brian,

Where I'm going with this is I think the shared file is what is ultimately making the "Response for no Message Sent" error. Once the shared files are dealt with, that error shouldn't be seen any more. Do you have any cases of errors where there isn't shared files involved? If not, then I'm going to start the process of permanently removing your project from my drives so that you won't have to worry about us having any of your code.
-----------------------------------------------------------------------------------------------
Thanks,
Beth Kieler, MCTS
Technical Support
SourceGear LLC
Brian C Drab

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Response for No Message Sent! - SOS 5.0.1

Post by BrianDrab » Fri Jan 29, 2010 10:01 am

From: Brian Drab
Sent: Friday, January 15, 2010 11:43 AM
To: support@sourcegear.com
Subject: RE: SourceOffSite and VS 2008 {218654}

I was simply letting you know that VSS deals with this scenario, and your previous version of SOS didn't give the Response message that your current version does. Go ahead and delete the project.
Brian C Drab

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Re: Response for No Message Sent! - SOS 5.0.1

Post by Beth » Wed Feb 03, 2010 4:02 pm

A bug has been logged on this.

F: 15219
Beth Kieler
SourceGear Technical Support

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Response for No Message Sent! - SOS 5.0.1

Post by jclausius » Wed Mar 31, 2010 10:36 am

Brian,

We've identified a scenario where the Response for No Message Sent is occurring, and fixed it in SOS 5.0.2. Look for the maintenance release to be out today (March 31, 2010).
Jeff Clausius
SourceGear

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Response for No Message Sent! - SOS 5.0.1

Post by BrianDrab » Wed Mar 31, 2010 11:18 am

THANK YOU!!!!
Brian C Drab

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Response for No Message Sent! - SOS 5.0.1

Post by jclausius » Wed Mar 31, 2010 12:45 pm

NP.

In our testing scenario, I identified one issue causing this behavior. I'm hopeful it is the same state of things in your solution/project. Please let me know if this release resolves the issue.
Jeff Clausius
SourceGear

BrianDrab
Posts: 98
Joined: Tue Mar 25, 2008 1:27 pm
Contact:

Re: Response for No Message Sent! - SOS 5.0.1

Post by BrianDrab » Tue Apr 06, 2010 9:34 pm

I can verify that the "Response for No Message Sent!" message is resolved in SOS 5.0.2. I can also verify that SOS still doesn't allow you to deal with shared files as nice as the VSS client.

Thanks for fixing the message.
Brian C Drab

jclausius
Posts: 3660
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
Contact:

Re: Response for No Message Sent! - SOS 5.0.1

Post by jclausius » Tue Apr 13, 2010 2:22 pm

Glad to hear the Response for No Message Sent issue has been resolved.
Jeff Clausius
SourceGear

Post Reply