Vault v10.0.1 and DTS 2017

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Posts: 3599
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Tue Apr 24, 2018 9:14 am

I think my post may not have been clear. The link I used to download and install the extensions came from the page you mentioned. To sum it up, I installed Visaul Studio 2017 and then added the SSDT extensions from one of the download links found on that same page.

On that page, just after the second paragraph. Look for "Download SSDT for Visual Studio 2017 (15.6.0)" which has a link of . Also on that same page, see ( ... tudio-2017 ), I tried the "English (United States)" link ( ... lcid=0x409 )

However, you mention this is NOT the same thing used in your environment. What link should I use install DTS 2017?

Also, have you tried creating an offline Visual Studio 2017 installation along with the SSDT for Visual Studio 2017 and testing that on the machine without internet access?
Jeff Clausius

Posts: 54
Joined: Wed Dec 15, 2010 9:02 am
PostPosted: Thu Apr 26, 2018 1:32 pm
The installation was found here: ... erver-2017

From here, choose:

Download SSDT for Visual Studio 2017 (15.6.0)

After installation of this, we added the extention provided by SourceGear.

Posts: 3599
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Thu Apr 26, 2018 2:39 pm
OK. To summarize, here are the steps I performed in the previous post:

1) I installed Visual Studio 2017 Pro from here - (left hand side, chose Visual Studio Pro for this link - ... nal&rel=15 ) . Ran the web install.

How did you get the Visual Studio 2017 instance on the machine? Did it come from one of the Visual Studio SKUs on the links I posted above?

2) Started Visual Studio 2017, went to Tools -> "Extensions and Updates", and chose to download / Install "SourceGear Vault Standard Extension" from the "Online" section.

3) Downloaded / Installed "Download SSDT for Visual Studio 2017 (15.6.0)". During the install, for "Install tools to this Visual Studio 2017 instance:" - "Visual Studio Professional 2017" checking the boxes for "SQL Server Database", "SQL Server Analysis Services" and "SQL Server Integration Services"

4) Created a database project in this post - posting.php?mode=reply&f=5&t=23028#pr79266

If you can get to the server, you can do a "File" -> "Vault Source Control" -> "Open from Vault" from within Visual Studio 2017 to "" using the "guest1.. guest 9" user (note, pwd is same as login), choose the "Initial repository" and the solution found in $/VS2017/Integration_Services_Project1/. This will partially get the project on your machine.

However, since the solution has an Integration project which does not define the files it controls, you'll need to use the Vault GUI client to GET all of the rest of the files to that same working folder used by the solution/project from within Visual Studio.

Once the files were retrieved to disk by the Standard GUI client, I reloaded Visual Studio and could check out / undo check out the *.dstx files within the project.


If I were to guess, I would say the installed Visual Studio did not come from the sources I used in step 1. As mentioned in this post - posting.php?mode=reply&f=5&t=23028#pr79269 - there are certain Visual Studio SKUs from Microsoft which support integrated Source Control (or there's a bug in their other SKUs that source control does not work - depending on your point of view).


The reason I mention using the Visual Studio SKUs from the link above is that some folks are having problems when using SQL Server standalone IDEs : ... forum=ssdt

https://developercommunity.visualstudio ... his-s.html

(Note, Mark Schmidt proposes a possible solution in a comment.)


Mike_F901's comment - ... erver-2017
Jeff Clausius

Return to Support (Vault)

Who is online

Users browsing this forum: No registered users and 8 guests