Moving ggdata database to another machine

If you are having a problem using Collab, post a message here.

Moderator: SourceGear

Posts: 6
Joined: Tue Mar 09, 2004 11:02 am
PostPosted: Wed Nov 10, 2004 5:10 pm
I successfully installed the SOSCollab system and everything was running on the same machine. We needed to host the ggdata db on our production SQL Server machine which is on a different machine on our network.

I have moved the database, all it's objects, and the gguser login to our production SQL server. Everything works now except the 'Server Administration' application. I get the following error whenever I try to launch it:

Error opening XML file - [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid column name 'Name'.

Here's what I did:
I installed with defaults using a local instance of MSDE and everything worked without errors.
Then I copied the ggdata db to our production SQL server.
Then I modified the System DSN (gg_sql_server) to point to this new SQL Server and confirmed that the connection worked using the gguser account with the same password as the SOScollab Admin pwd specified during the install. That worked perfectly.
Then I restarted the Primary and Web Server Services and they all fired up without errors.
Then I started the SOS client and it worked and I was able to browse around and use the admin functions like changing users and projects and such.
Then when I tried to launch the 'Server Administration' app I got the error listed above.
As long as all db communication funnels through this DSN, I don't see why this doesn't work?

Any help would be greatly appreciated.

Posts: 6
Joined: Tue Mar 09, 2004 11:02 am
PostPosted: Fri Nov 12, 2004 3:20 pm
I was able to fix the issue:

The problem was that the SQL Server I moved ggdata to had a default COLLATION of Latin1_General_BIN (which is case-sensitive).

I ran SQL Profiler and saw the following was giving me the error whenever Server Adminstrator program ran:

SELECT rep.sccrid, rep.Name, vss.SourceSafeIniPath
FROM sccrepositories rep, scc_vssdatabases vss
where rep.sccrid = vss.sccrid

The column rep.Name was throwing the error that it didn't exist. When I opened the table I saw that it did exist and that the only difference was that the column was called 'name' not 'Name' which obviously indicated case-sensitivity in my database COLLATION.

So I put that ggdata db into 'single-user mode and then executed the following to change the COLLATION to the SQL default collation:

alter database ggdata COLLATE SQL_Latin1_General_CP1_CI_AS

Then I took the db out of single-user mode and ta-da.....all is working great now.


Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Wed Nov 17, 2004 9:13 am
Wow, great troubleshooting. This would have been a tough one for us to diagnose. Just shows we have talented customers.
Linda Bauer
Technical Support Manager

Return to Support (Collab)

Who is online

Users browsing this forum: No registered users and 1 guest