I can't find my logs.

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
HKroll
Posts: 11
Joined: Thu Jan 16, 2020 8:25 am

I can't find my logs.

Post by HKroll » Thu Jun 10, 2021 8:04 am

Hi,
I recently had an issue logging into Vault. The first thing I tried was looking in the Source Gear Support forum, and I found several similar issues in which the users provided their logs for inspection.

I tried looking for my logs in the Windows/Temp folder as instructed, but when I go there, there's no file or folder with "sgvault", "sg", or "vault" in the name (I did a search for each). There are several log files (WTUSLVSE144844L-xxxxx), but I think these might be for Windows and not Vault.

Do you know if I should look somewhere else or if there's an error with our logging setup?

I was able to fix the login issue by re-installing the Vault application, but I feel that I should be able to find my logs in case of future issues.
Thanks!

Tonya
Posts: 726
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: I can't find my logs.

Post by Tonya » Thu Jun 10, 2021 10:11 am

Hello,

Perhaps you weren't on the Vault Server machine? The Vault Server log is in %windir%\temp\sgvault\sgvault.log on the server machine.

Tonya

HKroll
Posts: 11
Joined: Thu Jan 16, 2020 8:25 am

Re: I can't find my logs.

Post by HKroll » Thu Jun 10, 2021 1:01 pm

That makes sense - I was looking on my work laptop. However, my company is about to migrate our database from the server to the cloud next week. Is there a way for me to access the log files after that migration? Or would I need help from a cloud administrator?
Thanks!

Tonya
Posts: 726
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: I can't find my logs.

Post by Tonya » Thu Jun 10, 2021 2:19 pm

Hello,

I'm assuming that you'll still have access to the installation in the cloud. If not, you will need to obtain the log from someone who does.

Tonya

Post Reply