Command line client empty response

If you are having a problem using Vault, post a message here.

Moderator: SourceGear

Post Reply
seb1690
Posts: 5
Joined: Thu Jun 09, 2022 3:34 am

Command line client empty response

Post by seb1690 » Thu Jun 09, 2022 3:45 am

Hi,

I have standard vault client version 10.0.2 (936). I try to use a command line client in order to get the history of a folder but the response I receive is empty. The command seems to work fine though.

This is the command I use (I replaced all fields by XXXX):

vault HISTORY -user "XXXXXXX" -password "XXXXX" -host "XXXXX" -repository "XXXXXX" "XXXXXXXX"

And this the response I receive:

<vault>
<history />
<bugsreferenced />
<result>
<success>True</success>
</result>
</vault>


The succes value is "True" but the history content is empty. Of course the history of the requested folder is not empty if I verified it via the GUI. I tried the same command on another computer and it works correctly. I also tried to re-install source gear multiple time on my computer but it does not help.

What can I do? I need this command to work in order to use it from a Python script.

Thanks,
Seb

Tonya
Posts: 789
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Command line client empty response

Post by Tonya » Thu Jun 09, 2022 2:06 pm

Few questions for you:

1) Have you tried to perform the same history command specifying a different folder?

2) Does your CLC work properly for any commands?

Thanks,

Tonya

seb1690
Posts: 5
Joined: Thu Jun 09, 2022 3:34 am

Re: Command line client empty response

Post by seb1690 » Tue Jun 14, 2022 3:52 am

Hi Tonya,

Yes I tried on different folders and files and it never works.

CLC seems to work for other commands. I didn't try all of them but for example the PIN and LISTFOLDER commands are working fine (I just retried to be sure).

Why the HISTORY command does not work as expected?

Thanks,
Sebastien

Tonya
Posts: 789
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Command line client empty response

Post by Tonya » Wed Jun 15, 2022 9:37 am

Hello again,

Can you try to History command with options to see if this makes a difference? I have copied below a link to the Vault CLC Help guide, you will need to scroll down to the History section:

http://download.sourcegear.com.s3-websi ... tm#HISTORY

Thanks,

Tonya

seb1690
Posts: 5
Joined: Thu Jun 09, 2022 3:34 am

Re: Command line client empty response

Post by seb1690 » Wed Jun 22, 2022 12:15 am

Hi,

I tried with -rowlimit / -datesort / -includeactions / -norecursive and the result is the same. This is really boring.

Hope you can help me.

Thanks,
Seb

Tonya
Posts: 789
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Command line client empty response

Post by Tonya » Wed Jun 22, 2022 7:04 am

This is not an easy problem to troubleshoot since it appears to be specific to your machine. Perhaps your Vault Server log would be useful. Can you please send us your Vault Server log? The Vault Server log is in %windir%\temp\sgvault\sgvault.log on the server machine. Please include more information in regards to your environment (OS info) and your Vault license key (so we can locate your record in our customer service portal). When emailing support@sourcegear.com, please reference this thread.

Thanks,

Tonya

seb1690
Posts: 5
Joined: Thu Jun 09, 2022 3:34 am

Re: Command line client empty response

Post by seb1690 » Wed Jun 22, 2022 8:29 am

Hi Tonya,

Thank you for your answer. I cannot find the sgvault folder under C:\Windows\Temp. I also tried to search for "sgvault.log" on my C: disk and it found nothing.

About the Vault license key, where can I find it? I am working in a big company and my account has been added by somebody else.

Thanks,
Seb

Tonya
Posts: 789
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Command line client empty response

Post by Tonya » Wed Jun 22, 2022 9:23 am

Hello again,

The Vault Server log is in %windir%\temp\sgvault\sgvault.log on the server machine. You will need to have access to the Vault Server machine to obtain it or ask an admin for it. When you email the log, I may be able to locate your record based off your email domain. The Vault license key is located on the Server, it can be accessed using the Vault Admin Tool and it's under the licensing section.

Tonya

seb1690
Posts: 5
Joined: Thu Jun 09, 2022 3:34 am

Re: Command line client empty response

Post by seb1690 » Mon Jun 27, 2022 1:33 am

Hi,

Ok thank you, I just sent an email to support.

Regards,
Seb

Post Reply