Diff not working

If you are having a problem using SourceOffSite, post a message here.

Moderator: SourceGear

Post Reply
mmcbride
Posts: 7
Joined: Wed Dec 15, 2004 10:21 am

Diff not working

Post by mmcbride » Wed Dec 15, 2004 10:39 am

Hello, we have SOS Server 4.02 and VSS 6.0d on our server. When trying to do a Diff for different file versions in Show History (on certain files) using SOS client 4.0.2 (or 3.5.2) it just hangs with an hour glass. (This happens using windiff.exe or sgdm.exe.) If the Diff button is hit several times a message box appears "Unable to create temporary directory for diff." The SOS log.txt file says "Exception getting file. Version not found." It works doing a diff between versions 10 and 11 for one of the files in question, but not between versions 8 and 9. It also seems to work fine on other files in the same database of the same type (cpp). I checked the analyze log file and there do not seem to be any errors related to this project at all. It works fine using a VSS client. I've seen this in other posts, but the files we're having problems with do not appear to be a different CASE in SOS than in VSS. Does anyone know how to resolve this issue?

Thank you!
Meredith
mmcbride

mmcbride
Posts: 7
Joined: Wed Dec 15, 2004 10:21 am

Post by mmcbride » Wed Dec 15, 2004 4:59 pm

I upgraded from SourceSafe 6.0d Build 9848 to 6.0d Build 31222 on the server (using Visual Studio 6.0 Service Pack 6) and it seems to have fixed the problem. :)

Alfetta159
Posts: 3
Joined: Fri Sep 09, 2005 3:43 pm

Post by Alfetta159 » Tue Sep 20, 2005 6:22 pm

Yeah, I concur.

The service pack is actually VisualStudio 6.0 SP6, but it is for VSS 6.0x.

I didn't think about installing this service pack because we don't have VS 6.0 installed on that server, just VSS 6.0d.

We also found that this hang problem manifested itself when trying to get a version from history. One of our users pointed out that the hanging seemed to be related.

Thanks for the advice.

ztnova

Re: Diff not working

Post by ztnova » Wed Nov 09, 2005 10:30 am

mmcbride wrote:Hello, we have SOS Server 4.02 and VSS 6.0d on our server. When trying to do a Diff for different file versions in Show History (on certain files) using SOS client 4.0.2 (or 3.5.2) it just hangs with an hour glass. (This happens using windiff.exe or sgdm.exe.) If the Diff button is hit several times a message box appears "Unable to create temporary directory for diff." The SOS log.txt file says "Exception getting file. Version not found." It works doing a diff between versions 10 and 11 for one of the files in question, but not between versions 8 and 9. It also seems to work fine on other files in the same database of the same type (cpp). I checked the analyze log file and there do not seem to be any errors related to this project at all. It works fine using a VSS client. I've seen this in other posts, but the files we're having problems with do not appear to be a different CASE in SOS than in VSS. Does anyone know how to resolve this issue?

Thank you!
Meredith
mmcbride
We have the same problem. When we try to diff two history files the mouse cursor sits on the hourglass forever. We updated our system to:

Visual Studio SP6
Visual SourceSafe 6.0d (Build 31222)
SourceOffSite (4.1.2)

Yesterday I updated SP6 and SourceOffSite but have not done a reboot because it didn't ask me to. We are going to reboot the server to see if that helps. Any other suggestions if this doesn't work?

kaleem khan
Posts: 2
Joined: Mon Jul 24, 2023 10:06 am

Re: Diff not working

Post by kaleem khan » Tue Jul 25, 2023 8:55 am

I am facing issues with VSS (Version Control System) on my laptop. When we compare versions and look at the differences, the program gets stuck, and you need to close and reopen VSS frequently. Please look into this issue as soon as possible, as it's causing inconvenience. When I try to diff to files in the history view, sos kind of freezes. I must press the stop current operation button. above 90 files it sos gets freezes below 90 files it is showing their versions.

source-offsite version 4.2.

pls, can you help me...

Tonya
Posts: 871
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Diff not working

Post by Tonya » Wed Jul 26, 2023 10:44 am

Hello,

I have responded to your support email requesting more information. Please respond when you have time.

Thanks,

Tonya

Post Reply