Vault Login Error

If you are having a problem using Vault, post a message here.
Post Reply
kmxsoft
Posts: 40
Joined: Mon Sep 14, 2015 12:34 pm

Vault Login Error

Post by kmxsoft » Tue Nov 28, 2023 7:46 am

I was using Vault this morning on my client without problem, but trying a new session fails.

The server logon works, but after a few seconds when it would be identifying the repositories the following message is displayed.

Code: Select all

System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.NullReferenceException: Object reference not set to an instance of an object.
   at VaultServiceBase.VaultLogManager.LogException(Exception e)
   at VaultServiceAPILib.VaultServiceAPISystem.LogException(Exception e)
   at VaultServiceAPILib.VaultServiceAPISystem.GetOpenSqlConn(VaultServiceDBConnectType vsDbType, VaultSqlConn& conn)
   at VaultServiceAPILib.VaultServiceAPISystem.DoLogin(Boolean allowwebonlyusers, Boolean bAdminLogin, HttpSessionState hss, String strHostname, String strLogin, String strPassword, String strRMKey, String& strAuthToken, String strDomain)
   at VaultServiceAPILib.VaultServiceAPISystem.DoLogin(Boolean allowwebonlyusers, Boolean bAdminLogin, HttpSessionState hss, String strHostname, String strLogin, String strPassword, String strRMKey, String& strAuthToken)
   at VaultService.VaultService.Login(String strHostname, Boolean bUseFullFiles, String username, String strEncryptedPassword, String strRMKey, String& strAuthToken)
   --- End of inner exception stack trace ---
I repeated the exercise on the server - which produced the same result.

How can I recover this?

Tonya
Posts: 856
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear

Re: Vault Login Error

Post by Tonya » Tue Nov 28, 2023 8:28 am

Hello,

My first suggestion is to make sure the Vault Server and SQL Server are running. I would also restart the Vault Server (using IIS).

Please let me know if this helps.

Thanks,

Tonya

Post Reply