XML stored procedures are not supported in fibers mode

A collection of information about Vault, including solutions to common problems.

Moderator: SourceGear


Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear
PostPosted: Mon Jan 03, 2005 4:24 pm
If you try to create a folder or add a file, and get the error “A database error has occurred (FailDBInsert)”, or see this error in the Vault client message pane:

"Server unavailable for transaction end.
Transaction failed."

there may be a problem with the configuration of the SQL server hosting the sgvault database. Check the contents of the Vault log file in %windir%\temp\sgvault. You may see lines that say “XML stored procedures are not supported in fibers mode”.

To fix this problem, launch SQL Enterprise manager and right click on the local database group, and choose properties. Go to the processor tab, and uncheck the box “Use Windows NT fibers”. You will be required to restart SQL server. If you are using MSDE, run isqlw and

sp_configure 'lightweight pooling', 0
RECONFIGURE
GO

You can also run this from Query Analyzer

More info at this link:

http://support.sourcegear.com/viewtopic.php?t=1373
Linda Bauer
SourceGear
Technical Support Manager

Return to Knowledge Base (Vault)

Who is online

Users browsing this forum: No registered users and 1 guest