Deleting files from repository

If you are having a problem using Vault, post a message here.

Moderator: SourceGear


Posts: 19
Joined: Tue Sep 12, 2006 3:12 pm
PostPosted: Fri May 02, 2008 7:51 am
I noticed some problem with Vault 4.1.1 (18060).
When I delete a folder from repository it becomes ghosted. It's ok.
When I delete a file, not folder, the file is deleted both from repository and from working folder. It's bad.
Seems, Vault v 3.5 or so did it correctly, not deleting local copy of the file.
I believe, once the behavior of Vault changed in this way, there should be an option available - to delete local copy of the file or not. By default - don't delete local copy.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Fri May 02, 2008 1:12 pm
We have a change coming on that in the next release.

Posts: 19
Joined: Tue Sep 12, 2006 3:12 pm
PostPosted: Fri May 02, 2008 2:47 pm
Excellent. Thank you!

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Mon May 05, 2008 1:30 pm
NP

Posts: 11
Joined: Mon Sep 10, 2007 4:31 pm
Location: Copenhagen, Denmark
PostPosted: Sat May 17, 2008 5:09 pm
Hello Beth,

Can confirm that your comment regarding the next release includes this point from Talamar

When I delete a file, not folder, the file is deleted both from repository and from working folder. It's bad.


We experienced this too and had bit surprised as we cannot find any description of this behavior in the manuals. Or at least, we did not expect it.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Mon May 19, 2008 10:21 am
we cannot find any description of this behavior in the manuals
I will get that logged as a bug to make users more aware of this.
F: 13730

The work around for now would be to undelete the file and either remove the working folder association for that area before deleting or to perform a Get to a different location on the file, before deleting and then moving it back to the area it needs to be in.

Posts: 19
Joined: Tue Sep 12, 2006 3:12 pm
PostPosted: Tue Jun 10, 2008 7:05 am
Thanks for fixing it.
Now it's ok.
One comment: the path to the file(s) being deleted might be quite long and thus not fit to the "Delete" dialog window listbox. In my case the first thing I did was not scrolling the text but attempting to drag the window border to make it wider instead, and ... oops - the window is not resizable. :( Why not to make it resizable? It would be quite usual.

Return to Support (Vault)

Who is online

Users browsing this forum: Google [Bot] and 14 guests