Configuring the 32-bit Server on a 64-bit Machine

A collection of information about Vault, including solutions to common problems.

Moderator: SourceGear

Post Reply
Posts: 27
Joined: Tue Oct 28, 2008 1:20 pm
Location: SourceGear

Configuring the 32-bit Server on a 64-bit Machine

Post by joe_sg » Fri Apr 03, 2009 3:35 pm

In Vault 5.0 / Fortress 2.0 we introduced our new Handoff feature, which performs a fast import of the latest versions from a VSS database and offers on-demand access to earlier VSS versions.

Handoff requires the 32-bit Vault/Fortress Server, with IIS running in 32-bit mode. After a standard install of the 32-bit Server on a 64-bit IIS7 machine, IIS may still be running in 64-bit mode, and you may see this message when you try to set up a handoff:


... because even though your server is in fact the 32-bit version, IIS7 is running in its default 64-bit mode.

To correct this situation, start the Internet Information Services (IIS) Manager: (Control Panel / Administrative Tools)

NOTE: This procedure should only be followed with the 32-bit version of Vault/Fortress Server to force it into 32-bit mode under a 64-bit OS. The 64-bit Vault/Fortress Server will not funtion in 32-bit mode.

Under Application Pools right-click VaultAppPool and choose Advanced Settings...


Set Enable 32-Bit Applications to True and click [OK].


The change should be immediate, with no need to reset IIS.

Now when you set up a Handoff source, you should see this:


... which is another way of saying "Congratulations!!" You are ready to start enjoying the benefits of Handoff.

Handoff's 64bit error message
64-error.png (10.58 KiB) Viewed 9142 times
VaultAppPool in IIS7 Manager
VaultAppPool.png (76.01 KiB) Viewed 9142 times
Setting "Enable 32-bit Applications" to True
IIS7x32.png (18.96 KiB) Viewed 9142 times
A successful configuration
success.png (14.96 KiB) Viewed 9142 times
Joe Ream
SourceGear Technical Support

Post Reply