Error Running Vault Admin Report

If you are having a problem using Vault, post a message here.

Moderator: SourceGear


Posts: 45
Joined: Wed Dec 15, 2010 9:02 am
PostPosted: Fri Apr 27, 2018 8:46 am
All Vault reports are generating an error.

Vault 10.

Running the Checked out items report gives me:


Server Error in '/VaultService' Application.

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".



<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.



<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Fri Apr 27, 2018 9:44 am
A better error can be found by trying that page in a browser right on the Vault server itself. When you try it there, what does it say?

It's possible you need the Reportviewer 2012 Runtime. More information about that can be found here: viewtopic.php?f=13&t=21868.
Beth Kieler
SourceGear Technical Support

Posts: 1
Joined: Sat May 12, 2018 2:24 am
PostPosted: Sat May 12, 2018 2:29 am
Hi Beth, Vault is constantly crashing in my PC. I upgraded to Windows 10 yesterday and I am facing this issue after that. Can you please help me?
What's appropriate section to post error log?
Recently contributed TeamViewer Alternatives

Posts: 14
Joined: Tue Oct 28, 2008 1:20 pm
Location: SourceGear
PostPosted: Mon May 14, 2018 10:56 am
Umashankar: Please post to the appropriate Vault or VaultProfessional support form and attach the relevant sections of your logs. Thanks.
Joe Ream
SourceGear Technical Support

Return to Support (Vault)

Who is online

Users browsing this forum: Google [Bot] and 4 guests