libcurl3 vs libcurl4

Support for our DiffMerge utility.

Moderator: SourceGear


Posts: 1
Joined: Fri Jun 01, 2018 2:33 am
PostPosted: Fri Jun 01, 2018 2:36 am
Hello,
I'm unable to use diffmerge on latest ubuntu (18.04) as that uses libcurl4 generally, and diffmerge uses libcurl3
which is a bummer.
Any idea how to sort it out?
Thanks,

[I made it work via modifying the binary to look for
libcurl.so.3 instead of libcurl.so.4 just that it seems
to be a bit of a hack]

Posts: 3531
Joined: Tue Dec 16, 2003 1:17 pm
Location: SourceGear
PostPosted: Fri Jun 01, 2018 9:22 am
Glad you were able to sort this out.

Did you use the /lib/ld-linux.so.2 --library-path" "PATH_OF_OLDER_LIBRARIES" "DIFFMERGE_BINARY" command line ?
Jeff Clausius
SourceGear

Return to Support (DiffMerge)

Who is online

Users browsing this forum: No registered users and 3 guests

cron