Work Item Tracking - sorting displays incorrect issues

If you are having a problem using Vault, post a message here.

Posts: 38
Joined: Wed Mar 15, 2017 1:39 pm
PostPosted: Wed Jun 13, 2018 8:48 am
Hi folks,

I've been having issues finding Work Items when I KNOW they are there. I think I've narrowed down the problem to a set of reproducible steps. We are using the web client.

1) I select Item Tracking tab and then click on our project name (we only have one currently).
2) I'm defaulted to see "My Open" items, so I click on Open to see everyone's items.
3) By default, the Fixed tab is selected for me. I click on the Open tab.

The steps above this are probably irrelevant, but I included them just in case. Here comes the "fun" stuff.

4) I see that I have 31 open items in the 6.8 Milestone. I click on the Assignee column header to sort. The first 20 items appear:

https://ibb.co/gGrhPd

Note that Assignee "hgrannis" is breaking the page.

5) I click on the arrow down below to see the rest of the items:

https://ibb.co/d1KxqJ

Including both pages, let's see what's assigned to hgrannis.

8045
6946
7951
8045
6946
7305

6946 is listed TWICE. And a random issue that should have appeared for hgrannis is missing completely from the list.

To test the theory that the items shown are only mucked up for the Assignee that breaks the page, I reversed the sort.

Now we see that Assignee "Skatsumata" breaks the page:

https://ibb.co/d7UK4d

Click on the arrow at the bottom to move to the next page:

https://ibb.co/b5oCPd

Now between the two pages, let's list what's assigned to skatsumata:

8076
8067

8136
8068
8076
8067

8060

8076 and 8067 are each listed twice, and two other items assigned to that Assignee are not displayed.

For all of the other users who didn't break the page, their items were consistently the same. None were missing or duplicated. (Although, when I sort, there doesn't appear to be a secondary sort in place, so they show up in a different order within the Assignee sort each time. I kind of expected a default secondary sort by Item ID for consistency of Item ordering.)

If it isn't already in there, we'd greatly appreciate it if you'd consider getting this issue into the next Vault Pro update. Thanks!!

Tara

Posts: 363
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear
PostPosted: Wed Jun 13, 2018 1:22 pm
Hi There!

Once again, thank you for the great details! I was able to reproduce the problem and I have the issue logged to be considered in an upcoming release. You can reference V:19962 if you'd like to check on the status in the future.

Thanks,

Tonya

Return to Support (Vault Professional)

Who is online

Users browsing this forum: No registered users and 3 guests

cron