Sync must be called on the UI thread

If you are having a problem using Vault, post a message here.

Posts: 2
Joined: Mon Jan 21, 2019 9:48 pm
PostPosted: Mon Jan 21, 2019 9:52 pm
When I try to add a new solution I get an error message "Sync must be called on the UI thread".
How do I resolve this issue?

Posts: 481
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear
PostPosted: Tue Jan 22, 2019 8:35 am
What version of Vault and Visual Studio are you using? We have a fix available for Vault 10.x and Visual Studio 2017 that you can download from our website to resolve this issue:

http://sourcegear.com/vault/downloads.html

Take note the Visual Studio 2017 extension notes "Updated client as of October 28, 2018 to address an issue in Visual Studio 2017 15.8.3 and later." If the download doesn't resolve the problem, please let us know.

Thanks,

Tonya

Posts: 2
Joined: Mon Jan 21, 2019 9:48 pm
PostPosted: Thu Jan 31, 2019 2:02 am
The VS update solved the issue "Sync must be called on the UI thread". Thanks!

But then there is another issue which have happened a few times recently. I add new files to av VS project, check them in without any errors but they are still present in pending changes. If i try to check in them again i get an error message "An item with the same name or object id already exists".

I am using Client and server 10.0.1 (30793)

Posts: 481
Joined: Thu Jan 20, 2005 1:47 pm
Location: SourceGear
PostPosted: Thu Jan 31, 2019 10:08 am
Hello again,

Did you have a previous check in attempt fail? If so, then the fail sits in the pending changes waiting. If you try to add again instead of just committing what is in the pending changes, then you will get duplicates.

Next time the problem occurs, please email your Vault Server log to support@sourcegear.com and refer to this post.

Thanks,

Tonya

Return to Support (Vault Professional)

Who is online

Users browsing this forum: No registered users and 0 guests