Visual Studio always displays login or repository dialog

A collection of information about Vault, including solutions to common problems.

Moderator: SourceGear


Posts: 2448
Joined: Wed Dec 17, 2003 5:03 pm
Location: SourceGear
PostPosted: Tue Jun 20, 2006 12:24 pm
Vault integration with Visual Studio is setup to automatically login to Vault if you use a profile. Additionally, you should only have to select the repository once during setup.

Visual Studio binding can sometimes get into a state where it does not send login or repository information to Vault, which causes Vault to have to display the login dialog and/or the repository dialog.

If Visual Studio binding gets into this state, try one of the options below to reset it:

1. Unbind and re-bind the project/solution. Go to File->Source Control->Change Source Control in Visual Studio, and choose Unbind, then Rebind on the top level solution file. If this does not help, try it on all the project files as well. If this works, and there are changes in the solution/project files (which you can check via the Vault GUI client), make sure you Check In the changes.

2. Do a new Open From Source Control from within Visual Studio to a fresh working folder (via File->Source Control->Open From Source Control). If you try this, you'll want to rename your current working folder, or choose a completely different working folder before doing the Open From Source Control. Also, this method will cause you to lose project state and user settings within Visual Studio for that particular project.

You should only have to do an Open From Source Control once in order to setup binding information.

3. Try to manually fix the MSSCCPRJ.SCC and project files.

A MSSCCPRJ.SCC exists (or should exist) in the working folder of any solution or project file that is under source control. It contains the binding information that is sent to Vault with which to login. See the KB at http://support.sourcegear.com/viewtopic.php?t=2474 for instructions on how to edit this file to contain the profile that you want to connect with.

Note that the profile information may already be correct in the MSSCCPRJ.SCC. If so, make sure the correct the information is in that file at all levels of the solution (for example, a solution can contain multiple projects, and the MSSCCPRJ.SCC file in each project should reflect the same profile information).

If all the MSSCCPRJ.SCC files are correct, check the project files themselves (such as .csproj for cs projects) in notepad for how binding information is stored. Find the lines:

SccProjectName = "SAK"
SccLocalPath = "SAK"
SccAuxPath = "SAK"
SccProvider = "SAK"

or their equivalents. If these entries do not have "SAK" as value, replace them with "SAK". This is Microsoft's way of telling Visual Studio to look for binding information in the MSSCCPRJ.SCC file instead of other user files in the working folder.

Return to Knowledge Base (Vault)

Who is online

Users browsing this forum: Google [Bot] and 0 guests