Vault 4.0.3 Missing Icons if the Splash Screen is turned off

If you are having a problem using Vault, post a message here.

Moderator: SourceGear


Posts: 3
Joined: Thu Aug 02, 2007 10:50 am
PostPosted: Thu Aug 02, 2007 11:18 am
Recently, we upgraded to the 4.0.3 client from the 3.x branch. Whenever I ran the client, I had no icons (in the toolbar, or in the folder tree). This was driving me crazy - nothing I did would fix it. Then I remembered that a while ago I had set the "ShowSplash" value in the registry to false (I dislike splash screens). Changing it back to "True" fixed the problem - now my Vault client has icons.

I assume somewhere in the function that is skipped by this value is some code that initializes resources?

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Thu Aug 02, 2007 3:05 pm
We've tried reproducing this on what we currently have setup and the same thing didn't happen for us. So that we can try making this happen, can you open your Vault client and go to Help - Technical Support and copy the information from there to me?

Also, from which previous version had you upgraded? That might make a difference here too.

Posts: 172
Joined: Wed Feb 01, 2006 8:45 am
PostPosted: Sat Aug 04, 2007 3:00 am
I can confirm this behaviour.

I uninstalled Vault client 3.5.2 and installed Fortress client 4.0.3. Running Fortress for the first time showed the splash screen and icons. Exited Fortress, change registry setting ShowSplash to False and restarted Fortress. Now no splash screen but also no toolbar icons are displayed. After setting ShowSplash back to True the icons are back again.

Relevant support info:

Client Information
Fortress Client Version: 1.0.3.15836
.Net Framework Version: 2.0.50727.832
Operating System: Microsoft Windows XP Professional
Service Pack: 2.0
OS Version: 5.1.2600
Total Physical Memory: 1022.48 MB
Time Zone: (GMT+02:00) Harare, Pretoria

Posts: 71
Joined: Mon Feb 16, 2004 8:38 am
PostPosted: Thu Dec 27, 2007 9:41 am
But note that in another thread has been reported as a bug and will be fixed.

Posts: 172
Joined: Wed Feb 01, 2006 8:45 am
PostPosted: Thu Dec 27, 2007 11:00 pm
Bit late to resurrect this thread but the bug still exists in Fortress 1.06, three versions after being reported.

Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
PostPosted: Fri Dec 28, 2007 10:21 am
It was logged in the other thread that was mentioned. Another person was able to reproduce it. It's logged and being worked on.

Posts: 1821
Joined: Thu Dec 18, 2003 11:39 am
Location: Sourcegear
PostPosted: Fri May 30, 2008 3:16 pm
This bug has (finally) been fixed in Vault 4.1.2.
Subscribe to the Fortress/Vault blog

Return to Support (Vault)

Who is online

Users browsing this forum: Exabot [Bot] and 14 guests

cron