Various Errors - Need help

This forum is now locked, since Gold Support is no longer offered.

Moderator: SourceGear

Locked
jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Various Errors - Need help

Post by jkp*74 » Mon Jan 07, 2008 11:39 pm

Attach is the log file. Also the screen shot.
Sometimes i can't even login as admin. However after a while, it was OK. I must have missed out something. I have attempted to clear cache & restart server. The problem still persist. Other users face the same problem.
I have posted it at http://support.sourcegear.com/viewtopic.php?t=3839 but decided to create a new entry here.
Attachments
No permission.jpg
No permission
No permission.jpg (37.14 KiB) Viewed 9584 times
vault_log.txt
Log File
(247.74 KiB) Downloaded 599 times
Invalid cast.jpg
Invalid Cast screen shot
Invalid cast.jpg (37.54 KiB) Viewed 9588 times
Joel
Micro Modular System
http://www.mmsis.com

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Tue Jan 08, 2008 11:25 am

I'm not sure if you'd still see the response from the other thread. Did you ever get that LDF file cut down? That's large enough that I would expect problems to arise from it.

lbauer
Posts: 9736
Joined: Tue Dec 16, 2003 1:25 pm
Location: SourceGear

Post by lbauer » Tue Jan 08, 2008 11:45 am

I would also suggest shrinking the Vault database log file. It could be contributing to some of the problems you are seeing. It certainly won't hurt . . .

If the database log file isn't a problem, there could be an issue with IIS settings or a firewall or router closing the connection.

Can you do the same operations on the Vault Server machine itself, using a client on the Vault server machine and connecting with "localhost" for the Vault server name?
Linda Bauer
SourceGear
Technical Support Manager

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Tue Jan 08, 2008 6:11 pm

I will try my best to figure out exactly how to shrink the log file. There is no firewall & all users are connected through LAN.

On IIS Setting, found this post: http://support.sourcegear.com/viewtopic.php?t=1014
I noted that the "Recycle worker process (in minutes):" option is unchecked under VaultAppPool but remain checked in DefaultAppPool. For Idle timeout option under Performance tab, both are unchecked. For 2 days the server log file began to capture error message at around 10 am. Would that be a coincident?
Joel
Micro Modular System
http://www.mmsis.com

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Wed Jan 09, 2008 12:19 am

Uncheck the "Recycle ..." option in DefaultAppPool & no more errors recorded until now. :D
I will still attempt to shrink the log file - i just hope that this action won't trigger yet another series of erros.
Joel
Micro Modular System
http://www.mmsis.com

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Wed Jan 09, 2008 8:46 am

Here's the instructions I usually recommend for shrinking the log file:
  • 1. Make a complete BACKUP of the database. (This is a MUST DO step!! You need to be able to recover if something goes wrong. If you have one, then continue.)
    2. Execute 'BACKUP LOG sgvault WITH TRUNCATE_ONLY'
    3. Execute this entire section:

    Code: Select all

    USE sgvault 
    GO 
    
    DBCC SHRINKFILE (sgvault_log) 
    GO
    4. Make a complete BACKUP of the database with the truncated log. (This is a needed so that if you have to restore, you don’t have to restore the huge log again. Huge logs will not restore in SQL 2000 sometimes.)

jkp*74
Posts: 147
Joined: Wed Dec 15, 2004 9:42 pm
Contact:

Post by jkp*74 » Sun Jan 13, 2008 7:43 pm

The problem already resolved. Please see http://support.sourcegear.com/viewtopic.php?p=38273
Joel
Micro Modular System
http://www.mmsis.com

Locked