Dragnet Still Supported?

If you are having a problem using Dragnet, post a message here.

Moderator: SourceGear

Locked
ZackJones
Posts: 131
Joined: Mon Mar 08, 2004 6:30 am
Location: Warner Robins, GA

Dragnet Still Supported?

Post by ZackJones » Tue Feb 26, 2008 8:18 am

Is Dragnet, as a separate product, still being updated by Sourcegear or to get the most current version do we need to upgrade to Fortress?

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Tue Feb 26, 2008 11:49 am

Dragnet and Fortress are a bit different. Fortress has all the features of Dragnet plus the source control capabilities of Vault plus a few additional things. Dragnet can now be found on our Legacy Software page. If you are not yet on Dragnet 1.0.7, then you can still upgrade to that version. If you wish to move onto Fortress, then you will want to talk to our sales department (sgstore at sourcegear.com) to see what the pricing would be like for you, and then I can help you with the switch.

If you have technical problems with Dragnet, we will still try to help you.

ZackJones
Posts: 131
Joined: Mon Mar 08, 2004 6:30 am
Location: Warner Robins, GA

Post by ZackJones » Wed Feb 27, 2008 6:32 am

Hi Beth,

Thanks for the reply. We've actually bought 13 licenses to Fortress but haven't upgraded because we don't have confidence in the product yet so we're sticking with Vault 3.5.2 and Dragnet 1.07 for now. I do have the latest version of Dragnet and have been getting a TON of errors were I'm sent to the Error page and have to reset my login. This happens a good 10-15 times a day. Is there any sort of setting I can check in Dragnet to see if something isn't configured properly on the server?

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Wed Feb 27, 2008 7:18 pm

Can you go to your dragnet server log? That would be in C:\Windows\temp\sgdragnet. That should show an error there.

ZackJones
Posts: 131
Joined: Mon Mar 08, 2004 6:30 am
Location: Warner Robins, GA

Log Sample

Post by ZackJones » Thu Feb 28, 2008 10:57 am

Here's a snippet. If you want the whole unedited log file let me know and I'll email it to you.

Code: Select all

2008-02-28 10:07:24.869 Configured Options: :    LogLevel - Quiet  LogReverseDNSLookup - True
2008-02-28 10:07:25.556 foo.com (1.1.1.1)- : Helpers::ListProjects Session Timed Out
2008-02-28 10:07:25.588 foo.com (1.1.1.1)- : Helpers::ListUserPreferences INSERT statement conflicted with COLUMN FOREIGN KEY constraint 'fk_userprefs_users'. The conflict occurred in database 'sgdragnet', table 'users', column 'uid'.  The statement has been terminated.
2008-02-28 10:07:25.588 foo.com (1.1.1.1)- : Helpers::ListProjects Session Timed Out
2008-02-28 10:07:25.588 foo.com (1.1.1.1)- : Helpers::ListProjects Session Timed Out
2008-02-28 10:07:25.775 foo.com (1.1.1.1)- : Helpers::ListProjects Session Timed Out
2008-02-28 10:07:25.791 foo.com (1.1.1.1)- : Helpers::ListUserPreferences INSERT statement conflicted with COLUMN FOREIGN KEY constraint 'fk_userprefs_users'. The conflict occurred in database 'sgdragnet', table 'users', column 'uid'.  The statement has been terminated.
2008-02-28 10:07:25.791 foo.com (1.1.1.1)- : Helpers::ListItemEdit Session Timed Out
2008-02-28 10:07:25.806 foo.com (1.1.1.1)- : Helpers::ListProjects Session Timed Out
2008-02-28 10:07:25.806 foo.com (1.1.1.1)- : Helpers::ListProjects Session Timed Out

ZackJones
Posts: 131
Joined: Mon Mar 08, 2004 6:30 am
Location: Warner Robins, GA

Post by ZackJones » Tue Mar 04, 2008 9:43 am

Knock knock -- any feedback from Sourcegear on this?

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Wed Mar 26, 2008 9:21 am

Sorry for the delay.

Try a few of the suggestions from this thread: http://support.sourcegear.com/viewtopic.php?t=6601. In that thread a user's firewall was blocking requests.

Is there anything on this machine which may be interferring with HTTP requests?

Try deleting out any cookies and try again.

ZackJones
Posts: 131
Joined: Mon Mar 08, 2004 6:30 am
Location: Warner Robins, GA

Post by ZackJones » Wed Mar 26, 2008 9:22 am

I dealt with Jeremy through email and we resolved the issue. Switching the application pool for Dragnet so it uses the same one that Vault uses fixed my problems.

Beth
Posts: 8550
Joined: Wed Jun 21, 2006 8:24 pm
Location: SourceGear
Contact:

Post by Beth » Wed Mar 26, 2008 4:17 pm

Thanks for the follow up.

Locked